Error when trying to run an Application with auto-profile on the Nsight Compute GUI

I’m using an Orin Jetson AGX. The CLI version of Nsight Compute works fine.
I get the following error when trying to profile an application by using the GUI.
Host, NVIDIA Nsight Compute,Failed to prepare kernel for profiling

I’m currently using the 2022.4.0 version. I’m doing this from my laptop by ssh’ing into the Orin from Nsight Compute. I’ve set the target to ARM64 SBSA.
I’ve also tried running the Nsight compute profiler on the ORIN itself and I get a failed to communicate with the Application Error.

I have seen other forums with a similar issue and tried the 2019 version as suggested but to no avail.
Please let me know what I can do to fix this.

Hi Sampath ,

are you able to profile any code at all ? or does Nsight compute fail for everything ?
How was Nsight Compute installed ?

Hi Neel,

I can only profile with the Nsight Compute CLI. I can’t do it with the GUI.

Did you install the Nsight suite using SDKmanager ?

Hi Neel,

I did it separately. How do I install the sdk manager and should I uninstall the version of nsight compute I installed already?

The standalone Nsight Suite is not for jetson.
Please reinstall it with SDK manager.
Nsight Compute is part of CUDA toolkit and the latest version for Jetson is still 2022.2

SDK manager details :

Hi Neel,
I installed the 2022.2 version with the sdk manager and I get the same error.


Profiler needs to launch application as Root, please make sure you are connected as root.

Does the application compile and run without the profiler ?

You might need to setup the root password first

The process is like this:

1. Setup root password

$ sudo passwd root

2. Edit /etc/ssh/sshd_config

diff --git a/sshd_config b/sshd_config
index a32dc1d..d21cacd 100644
--- a/sshd_config
+++ b/sshd_config
@@ -30,6 +30,7 @@
 #LoginGraceTime 2m
 #PermitRootLogin prohibit-password
+PermitRootLogin yes
 #StrictModes yes
 #MaxAuthTries 6
 #MaxSessions 10
@@ -54,7 +55,7 @@
 # To disable tunneled clear text passwords, change to no here!
 #PasswordAuthentication yes
-#PermitEmptyPasswords no
+PermitEmptyPasswords no
 # Change to yes to enable challenge-response passwords (beware issues with
 # some PAM modules and threads)

3. Reboot

$ sudo reboot

Then in Nsight while connecting the target you can ssh into root to launch the application

Hi Neel,

Thanks for the information. I’ll try it out now.

Hi Neel,

I managed to login as root but I still run into the same issue.

Can you try profiling a cuda sample while root ?
are you connecting to aarch64 sbsa?

Hi Neel,

The same thing happens for the samples. I’m using aarch sbsa.


Please use aarch64 instead.
aarch64-sbsa is for ARM-based CPU cluster, not Jetson.

The latest Nsight Compute from JetPack 5.1 should be 2022.02.


Hi AastaLLL,

Changing it to aarch64 works.
Could you please advise me to on the other issue as well.
I’d like to know how to figure out why the kernel takes different execution times on different runs of the application.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.