Error when trying to run free space segmentation DNN apps

Hello,
I’m trying to do free space segmentation with a Jetson Nano board and a RealSense camera.

I followed these instructions : https://docs.nvidia.com/isaac/isaac/packages/freespace_dnn/doc/freespace_segmentation.html
I deployed the app on the Jetson, and when I try to run it there with ./packages/freespace_dnn/apps/freespace_dnn_inference_image – --config inference:packages/freespace_dnn/apps/freespace_dnn_inference_medium_warehouse_tensorrt.config.json
I get the following error : PANIC packages/ml/TensorflowInference.cpp@46: Ill-formed tensor info list.

I also tried to modify freespace_dnn_inference_v4l2 application to use the RealSense camera, and I get the same error.

Small update on this :

  • I have tried to use TensorRTInference component instead of TensorflowInference, I get the same kind of error.
  • I have tried another neural-network based app ( 2D Skeleton Pose Estimation ) which uses TensorRTInference, and it worked.

So I’m still stuck on this matter, and would appreciate some help.

Hi gatein_g,
To run the deployed app on Jetson (without bazel) please remove the extra " --" . These are added to separate the parameters given to bazel to the ones given to the application.
Should be:
./packages/freespace_dnn/apps/freespace_dnn_inference_image --config inference:packages/freespace_dnn/apps/freespace_dnn_inference_medium_warehouse_tensorrt.config.json

When running with bazel on host you should still include the extra " --".

2 Likes

Thank you, this was indeed the problem.