Error when trying to run python tutorial in Isaac SIM (ubuntu)

I am trying to get the example from:

6. Custom RL Example using Stable Baselines

…working on an installation of Isaac SIM through Omniverse on Ubuntu 20.04

I have set up the and according to instructions in the tutorial.

However, whenever I run the command


I get the following return in console:

[5.420s] [ext: omni.kit.window.title-1.1.2] startup
[5.421s] [ext: omni.replicator.isaac-1.3.2] startup
[5.644s] [ext: omni.isaac.kit-0.2.1] startup
[5.645s] [ext: omni.isaac.sim.python.gym.headless-2022.1.1] startup
[5.646s] Simulation App Starting
/home/kmh/.local/share/ov/pkg/isaac_sim-2022.1.1/ line 40: 72446 Killed                  $python_exe "$@" $args
There was an error running python

Does anyone know why this is happening?
I cannot reproduce this error in a windows environment on the same machine.

Hi @kmhytting

The example should work on Ubuntu 20.04. Have you tried running the script provided in the Isaac Sim package? You can run it from ~/.local/share/ov/pkg/isaac_sim-2022.1.1/standalone_examples/api/omni.isaac.gym:


It turned out that I did not have the recommended RAM installed to run Isaac Sim since I only had 16GB. However, a temporary fix was to increase my swap partition!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.