Error while loading modules on Ubuntu 19.04

the modulefiles should be fixed.
https://modules.readthedocs.io/en/latest/MIGRATING.html#migrating-from-v4-1-to-v4-2

What do you mean by “should be fixed?” Is there something currently broken/wrong with them?

When trying to load them I got this error :

module load /opt/pgi/modulefiles/pgi/2019                                                        Module ERROR: Modulefile requires at least Modules version 2019#####################################################################
In '/opt/pgi/modulefiles/pgi/2019'
Please contact <root@localhost>

According to https://modules.readthedocs.io/en/latest/MIGRATING.html#express-modules-compatibility-of-modulefile-with-versioned-magic-cookie The module version must be changed from 2019 to the minimum version of Modules required to interpret the modulefile.

That looks like a bug, we’ll have to dig into it deeper but for now what happens if you edit the module files and change 2019 to something like 1.0?

I changed it before reporting, and It works.

Good to know. The required module version at the top should be 3.2.10, I think. So this does look like a bug on our part. TPR #27615 has been opened to address the issue.

I believe this issue has been fixed as of the 19.7 release. If you have a PGI Professional Edition subscription, you should try upgrading to that release, and let us know if you still see the issue.

If you are using PGI Community Edition, then this fix will be available with the 19.10 update. You can use the workaround Alex suggested above to fix the problem in the meantime.

Very sorry for any inconvenience caused by this issue.

+chris