Error while loading shared libraries:


I’m working on the detectnet_v2.ipynb notebook from TLT tutorial. In it I trained a resnet10 detector in a V100 GPU without problem.
However, when I transfered it to my Jetson Xavier NX, when I run the command:

./tlt-converter ./resnet10_detector.etlt -k $KEY -c ./calibration.bin -o output_cov/Sigmoid,output_bbox/BiasAdd -d 3,384,1248 -i nchw -m 64 -t int8 -e ./resnet10_detector.trt -b 4

I get the following error:

./tlt-converter: error while loading shared libraries: cannot open shared object file: No such file or directory

The files I transfered to my Jetson in the /deepstream-5.0/samples/experiment_dir_final folder are:

  • calibration.bin
  • calibration.tensor
  • resnet10_detector.etlt
  • resnet10_detector.trt.int8
  • tlt-converter

I’ve already tried using tlt-converter from here and tlt-converter 6.0 from here with the same error.

Any ideas what I’m doing wrong?

Solved it myself.
Turns out I’m running TensorRT 7, so I downloaded tlt-converter 7 from here and everything worked fine.