Error while replacing the ResizeBilinear with Conv2DTranspose using graphsurgeon

Description

Error while replacing the ResizeBilinear unsupported op with Conv2DTranspose op using graphsurgeon

Environment

TensorRT Version: 4.0.1.6.
GPU Type: NVIDIA Tesla V100
Nvidia Driver Version: 396.26
CUDA Version: 9.0
CUDNN Version: 7.6.3
Operating System + Version: Ubuntu16.04
Python Version (if applicable): 3.6.8
TensorFlow Version (if applicable): 1.15
** Graphsurgeon** : 0.4.5

Code snippet

import tensorflow as tf
from tensorflow.core.framework import types_pb2
import graphsurgeon as gs
graph = gs.DynamicGraph(‘frozen_graph.pb’)
##Add new node
node = tf.NodeDef()
node.op = ‘Conv2DTranspose’
node.name = ‘Conv2DTranspose’
graph.append(node)
##want to replace ResizeBilinear with Conv2DTranspose layer
next = graph.find_nodes_by_op(“ResizeBilinear”)[0] # assume only one node is found
node.input = next.input
next.input = [node.name]

Error :

line 32, in add_plugin
node.input = next_.input
AttributeError: Assignment not allowed to repeated field “input” in protocol message object.

Hi @letdivedeep,

Request you to try the latest TRT release for fixed issues and improved performance.
Thanks!

Thanks, @AakankshaS for the reply.

I tried with the latest version, still the same error

I have attached the frozen_graph.pb file to reproduce the error: