error while running over camera


I have got my jetson nano, and while trying to connect to camera and run python it throws this error

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:532 Failed to create CaptureSession

Any help is appreciated!


Is there any camera connected to the Jetson Nano?

From your log, it looks like the camera cannot be opened.

Failed to create CaptureSession

By the way, could you share the source of with us?

I figured it out the problem. it was related to OS, as the OS got locked the camera (might be I was running gst before) and I could not run another program to use the camera.

Thanks for the feedback.
Is the application good now?

I just run that for checking the live camera, I switched to running Yolov3. Its run successfully, the only concern is that it is very slow I can say with 7s delay or more.
Do you have any suggestion about how to improve it?


Could you try if maximizing the device performance helps?

sudo tegrastats


I am seeing this on my lepord imx334 some time, I have to reboot, so is it a driver lock up type probem?


Sorry that we need more information to figure our the cause.
Would you mind to share the detail error log with us?


my gstream application gets this error. what detail error log do you require.


Did you see any error log when the creation failed?


SCF: Error BadParameter:  (propagating from src/api/CameraDriver.cpp, function getSourceByGuid(), line 453)  ...


dmesg does not show anything, I am using a leporard imaging camera on R32.1

Does nvgstcapture-1.0 working?
TO get more information from below command.

sudo su
kill the process of argus_daemon/nvargus-daemon or nvcamera-daemon
export enableCamPclLogs=5
export enableCamScfLogs=5
/usr/sbin/argus_daemon(nvargus-daemon) option for argus
/usr/sbin/nvcamera-daemon option for gst-launch

launch camera from another console

Hi terrysu50z,

Which camera and nano carrier board are you using? Could you take a picture about the whole camera kit for us if possible?

back to working on the camera,
missing /usr/sbin/argus_daemon on my tx2 32.3.1

New info on debugging a Failed to create CameraProvider

oops it’s nvargus-daemon

nvidia@nvidia-desktop:~$ ls /usr/sbin/nvargus-daemon

Hi Sariag,

Could you please let me know how to resolve this issue. Even am facing the same probelm

Hi Friends,

I have connected my camera module to the NVIDIA Jetson Nano. After that, i run a camera launch command to check whether it is working fine or not.

The camera module is working fine and i run my code then i got the error as mentioned below:

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:568 Failed to create CaptureSession

My Camera module is IMX219. Can anyone please help me out of this…

Thank you in Advance…


Please help to open a new topic for your issue. Thanks