Error while running the deployed file in jetson nano (cannot access '/dev/video*:No such file or directory)


I have an issue with running ELF file which is yolo 2 detector deployed in jetson nano

After the succefully of deployment when i run the ELF file from terminal i have the following error

./yolo2detectobject.elf ls :cannot access '/dev/video*:No such file or directory
usupported camera resolution.
Please select of the following supported resolutions[/code]

I tried to run the file from linux in the folder where the ELF file saved but cannot working

I am using Raspberry camera 5MP to jetson nano


It looks like there are some issue on your camera.

1. Is it a USB camera?
Could you check if it is well connected to the Jetson Nano first?

2. Please also check which node your camera is mounted at.

ll /dev/video*

3. And you will need to check if the camera is supported by the GStreamer.

$ v4l2-ctl --all


Hi a.elhanashi,

Is this still an issue to support? Any result can be shared?

Hi kayccc

Yes I have ordered the right camera which is raspi Model 2 and it worked successfully

Thanks for your support