Error with bazel when building the sample demos

Hi,

I have successfully installed Isaac SDK on a fresh install of Ubuntu 18.04, on my desktop.

When I follow the tutorial and try to build the demo stereo_dummy I have the following error:

~/workspace/isaac$ bazel build //apps/samples/stereo_dummy
Starting local Bazel server and connecting to it...
ERROR: /home/cyril/workspace/isaac/packages/dummies/BUILD:5:12: Configurable attribute "data" doesn't match this configuration (would a default condition help?).
Conditions checked:
 //engine/build:platform_x86_64
 //engine/build:platform_jetpack42
ERROR: Analysis of target '//apps/samples/stereo_dummy:stereo_dummy' failed; build aborted: 

/home/cyril/workspace/isaac/packages/dummies/BUILD:5:12: Configurable attribute "data" doesn't match this configuration (would a default condition help?).
Conditions checked:
 //engine/build:platform_x86_64
 //engine/build:platform_jetpack42
INFO: Elapsed time: 1.179s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (11 packages loaded, 41 targets configured)

Here is my configuration:

~/workspace/isaac$ uname -a
Linux cyril-workstation 4.18.0-17-generic #18~18.04.1-Ubuntu SMP Fri Mar 15 15:27:12 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Here is my bazel version:

~/workspace/isaac$ bazel version
Build label: 0.19.2
Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar
Build time: Mon Nov 19 16:25:09 2018 (1542644709)
Build timestamp: 1542644709
Build timestamp as int: 1542644709

Here are my Nvidia drivers version:

~/workspace/isaac$ nvidia-smi 
Wed Apr 24 14:24:42 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 418.56       Driver Version: 418.56       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 106...  Off  | 00000000:01:00.0  On |                  N/A |
|  0%   60C    P0    31W / 200W |    622MiB /  6075MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1847      G   /usr/lib/xorg/Xorg                           310MiB |
|    0      1991      G   /usr/bin/gnome-shell                         309MiB |
+-----------------------------------------------------------------------------+

I have the same error when I try to build any of the sample projects with Bazel.
Anybody knows how to solve that issue ?

Thanks!

same problem, any solution?

I see you have made some efforts to fix this issue. I re-executed install_depedencies.sh, still got the same error.

@Cyril_J:

From the error message, I guess maybe somehow the file ‘.bazelrc’ has incorrect content. Try ‘ls -a’ to see if it is there and ‘cat .bazelrc’ to confirm the content.

Where should .bazelrc be? I googled it, and mostly likely .bazelrc file should be in workspace directory or home directory like ~/.bazelrc. However, I cannot find it. Could you provide your .bazelrc file and let me know where should I place it. Thank you in advance.

@dliu1030

The ‘.bazelrc’ file could be found in isaac sdk release package.

Thank you a lot. I confirm this, in my previous isaac directory, there was no .bazelrc file (I guess because I used file manager to extract isaac release into a directory, the hidden file was omitted).
I use tar this time, everything works as explained in the user guide. The issue is fixed now!!!

1 Like

I confirm this was the issue, the hidden file .bazelrc was not extracted using the Archive Manager!
It worked using these commands:

mkdir ~/isaac
tar -xJvf isaac_sdk-2019.1-17919.tar.xz -C ~/isaac/

It would be nice to add that to the tutorial.

2 Likes