error:2406C06E:random number generator:RAND_DRBG_instantiate:error retrieving entropy

Hello, when I call the rsa encryption and decryption functions of the openssl library in a trust environment, I keep getting the message “error:2406C06E:lib(36):func(108):reason(110)”; I use “openssl errstr 2406C06E” After checking, the specific prompt is “error:2406C06E:random number generator:RAND_DRBG_instantiate:error retrieving entropy
"; I referred to this topic “OpenSSL error 2406C06E”, I added relevant parameters to this file “lib/lib/openssl/Crypto-config-trusty.mk”; I also added these two functions "

static const char rnd_seed = “string to make the random number generator think it has entropy”;
RAND_seed(rnd_seed, sizeof rnd_seed);

", recompile and refresh, but still get the same error, I don’t know if I missed something, please help me ,Thanks

hello Barlow,

could you please share more details about your environment setups,
for example, what’s your Jetpack release version, what kind of the keys you’ve applied.

hello, JerryChang
I have solved this problem. Anyway, thank you for your reply。

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.