Errors during flashing Jetson Orin NX

I’m fairly new to working with Jetsons and Jetson Orin NX in particular. I’m in the process of building a Linux kernel to accommodate for WireGuard VPN and some peripherals since the original setup does not support them. I tried to follow all the guides and procedures I found very strictly but unfortunately I did something I cannot reverse. Now it just turns on, shows Nvidia logo on the display briefly and then turns off (or at least I think it does - SSD diode blinks). I tried to flash it using NVidia SDK but it didn’t work (logs attached). In order to keep experimenting I desperately need a reliable method to restore my Orin to factory defaults and original OS.

logs.txt (1.8 KB)


couple of mistakes here:

  1. For Orin NX, SDK Manager supports it only when it’s used with an Orin Nano DevKit, please use initrd flash manually if you want to use it with a Xavier NX DevKit.
  2. For the backup/restore tool, you have to manually choose the storage device to be used; for example, -e nvme0n1, or it would use eMMC by default, which is not available on Orin NX/Nano.

For the error log:

09:45:45 INFO: Flash Jetson Linux - flash: [ 0.5380 ] Sending bct_br
09:45:50 ERROR: Flash Jetson Linux - flash: [ 0.5902 ] ERROR: might be timeout in USB write.

this issue has been around for while, and currently we would suggest trying for a different USB port/cable, or use Ubuntu 18.04 as the host PC in case it’s 20.04.

Or try this command on your host PC:

sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.