Errors on Tesla P100

I have a program which used nvcaffe and Tensorrt that works on P4 and 1080Ti, but when I run it on P100, segmentation fault happened when loading model.Even nvcaffe and Tensorrt’s samples did not work. I have tried cuda9.2 and cuda9, when use cuda9.2(run tensorrt mnist sample), the error would be “Cuda initialization failure with error 2”, and when use cuda9, segmetation fault will happen.

os: ubuntu 16.04


sounds like a configuration difference P4/1080Ti vs. P100. Can you provide the full traceback from the seg fault, and the full error output from “CUDA initialization failure”?

The CUDA initialization error indicates something wrong when CUDA runtime communicated with the CUDA driver.

One of the common error is the driver is older than the CUDA toolkit. Each release of CUDA ships with a driver. Only drivers of the same or later version numbers will work well with that CUDA toolkit.

Update your driver and try again?

Thank you for your reply, I have tried to use the newest driver and the driver included in cuda, all failed. Right now, we have roll back to P4, I will try more if we need to use P100