Errors running ZED Mini camera and Joystick application on Jetson Nano on KAYA

I am attempting to use the ZED Mini camera on the KAYA and use an XBOX One controller as the joystick to control the KAYA. On the host computer, I have used

./engine/build/deploy.sh --remote-user <username> -p //apps/samples/zed_camera:zed_camera-pkg -d jetpack42 -h <IPaddress>

(using the format from https://docs.nvidia.com/isaac/isaac/doc/getting_started.html ) and

./engine/build/deploy.sh --remote-user <username> -d jetpack42 -h <IPaddress> -p //apps/kaya:joystick-pkg

(using the format from https://docs.nvidia.com/isaac/isaac/apps/tutorials/doc/assemble_kaya.html ) to deploy them to the Nano, which is already attached to the KAYA. I then SSH into the KAYA, then use

cd deploy/<username>/zed_camera-pkg
./apps/samples/zed_camera/zed_camera

which leads to the following errors:

20 times of

A ZED-M has been detected but the camera sensors (imu) has failed to open. Please try to unplug/plug the camera again.

and finally with

ERROR   packages/zed/ZedCamera.cpp@136: ZED Error: CAMERA MOTION SENSOR (imu) NOT DETECTED
PANIC   packages/zed/ZedCamera.cpp@137: [ZedCamera] Error initializing Zed camera

The same error occurs for /apps/samples/stereo_vo and /apps/samples/stereo_matching_depth.

As for the joystick application, I receive the following errors:

ERROR   packages/dynamixel/gems/dynamixel.cpp@53: Cannot open port
...
PANIC   packages/dynamixel/gems/dynamixel.cpp@80: Servo doesn't support MOVING_SPEED

I was unable to find any posts about the first issue with the ZED Mini. But I downloaded the ZED SDK on the Jetson Nano, and the ZED Diagnostic seemed fine. The ZED Explorer and Depth Viewer worked as well. Furthermore, the applications /apps/tutorials/opencv_edge_detection/ as well as /apps/samples/v4l2_camera/ deployed on the Nano worked, and Sight at :3000/ showed live video coming from the ZED Mini attached to the Nano when running these two applications (but not for /apps/samples/zed_camera).

For the second problem, I saw a post ( https://devtalk.nvidia.com/default/topic/1051725/sdk/more-errors-in-kaya-build-instructions ) but was ultimately unresolved. I could not find the folder packages/dynamixel, much less the dynamixel.cpp file. This error occurs both when the controller is and is not attached to the host computer. The same error occurs for /apps/kaya/object_detection as well.

After downloading HardInfo on the Ubuntu (to obtain System Information and view USB devices), the USB device corresponding to the XBOX controller when plugged in shows only as “Microsoft Corp.”:

Device Information

  • Product
  • Vendor : Microsoft (www.microsoft.com)
  • Max Current: 500 mA

Misc

  • USB Version: 2.00
  • Class: (Unknown)
  • Vendor ID: 0x45e
  • Product ID: 0x2ea
  • Bus: 2

Host Computer:
Ubuntu 18.04 (dual-booted from Windows 10)
Graphics Card: GeForce GTX 960
Processor: Intel® Core™ i7-4930K CPU
uname -r shows : 4.18.0-24-generic
CUDA Version: release 10.0, V10.0.130
Bazel version: 0.19.2

Ideas on what’s happening? Any help is much appreciated!

hi, brain :
maybe you can check whether you have the right privilege to the write/read the ttyUSB0 port. if not, one easy way to solve it is to make ttyUSB0 file to be executable by the following command:
sudo chmod 777 /path/to/the/ttyusb0directory/USB0, hope it will help.

Brian were you able to resolve this?

Sorry for the late response!

The motors did end up working; turns out the ttyUSB0 path was set incorrectly in the configuration file. Thank you for bringing that up to my attention!

As for the camera, I have resorted to using the zed-python-api ( https://github.com/stereolabs/zed-python-api ), to which the examples provided satisfy my needs.

Thank you all for the help!