Establishing connection between Jetson Nano and Lidar Velodyne VLP 16je

Hello, I am trying to establish connection between Jetson Nano and Lidar Velodyne VLP 16.

The issue here is, when I try to enter the site, it takes around one hour of google chrome loading just to reach the site.

I tried pinging the IP, I receive a reply every 10 to 15 ms, which is not normal at all. I am connecting my Lidar via Ethernet cable, I have a Ethernet to USB converter, connecting the USb to the USB Port, because when I try to connect directly to the Ethernet port, I get that “Ethernet Disconnected” message.

What makes me think that this is not normal, I tried pinging my lidar using another CPU, which has Ubuntu running on it, i received replies within 0.8 ms I guess, so what should I do?

Hi there @ahmedtamer632, welcome to the NVIDIA developer forums.

I hope you don’t mind if I move your post over to the Jetson forums. You will get better coverage with the experts there.


Not sure if the USB take it as low speed device.
You may check the manual to connect to the RJ45 connector.

If you are using a direct Ethernet connection, you need to create a network on the Jetson with a static IP of
You can do this using the Network Manager.

By default, when Ethernet is connected to the Jetson the Jetson expects the network to assign it a network address. You will see this as IPv4 Method: Automatic (DHCP) in the Network Settings Manager. If you attach the Velodyne instead, the Jetson needs to create its own network and assign itself an IP address. is a commonly used address on local networks, and allows the Jetson to ‘see’ the Velodyne over on 201.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.