eth0 disappeared and shows up after reboot [SOLVED]

my TX1 lost the eth0 param in the “ifconfig” menu. This was an occasionally issue, solved by physically rebooting the TX1, but recently this problem occurs once a day, at least!

If I reboot the system physically or by the sudo reboot command, the eth0 param shows up again.
I tried to change the Connect Tech elroy revE carrier board (and also the cables and so on), but the problem is still here.

How can I solve it?


You might want to mention which L4T version is running (see “head -n 1 /etc/nv_tegra_release”). If you can, then try to run “dmesg --follow”, and after a failure mention the content at the end of the logs. Also, if it uses any kind of WiFi, mention that too (NetworkManager has a tendency to remove eth0 when it thinks WiFi should take over). Also mention how the address is configured, e.g., static, or via DHCP.

the output of the nv_tegra_release is:

# R28 (release), REVISION: 1.0, GCID: 9379712, BOARD: t210ref, EABI: aarch64, DATE: Thu Jul 20 07:45:59 UTC 2017

The command dmseg --follw is running, but at the moment, with the new carrier board, I haven’t a failure since friday! This is quite confusing because I was pretty sure that the problem was the TX1, but now it’s very probable that the carrier board is the guilty.

I’m not using wi-fi and I’m using a DHCP configuration.

I’ll continue to keep the logs updated, but I think that the new carrier board is the solution, do you confirm?

Thank you!

WiFi has been problematic, but wired ethernet and DHCP has been fairly solid. If wired drops out on one carrier but not another it does suggest the carrier board, and my own experience tells me probably the issue is more carrier board or external issues than it is module. More generally speaking, interfaces will drop out over signal issues, and so there are too many possibilities for what might do that than can be listed.

Were both carrier boards the same model? Were both using the same cable? Assuming they both started out working initially, then it could be assumed DHCP was good, but even that can’t be conclusive if the lease time differs (a DHCP server might renew a lease correctly and the next server doesn’t renew the lease). Are both using the same DHCP server or router? If a router appliance is used, can it be confirmed the router itself did not fail to be renewed (the router presumably gets its own IP via DHCP)? Did both start out initially working, or have any cases been observed of initial boot itself failing wired ethernet?

Yes, the carrier boards, the cables, routers and servers are the same. Additionally, we tested all the system in the first case, and the pair carrier + TX1 was the only with this issue.

The new carrier board actually has had some problems in the first hours, but now it’s connected since 3 or 4 days.