Eth0 gone after use Jetson-IO

Hey there. I’m using Jetson Xavier NX with JetPack 4.5.1. I’m use this computer on my robot and it controls engines on it through GPIO with PWM. To enable PWM I use Jetson-IO programm but after use of this programm ethernet seems not working. Eth0 interface is gone after that.

When I update all my packages on Xavier NX, apt also updates L4T packages. Typically, if L4T was updated, then I need to reconfigure GPIO pins because config resets to default and when it’s default, Ethernet works. But, again, if I change something on my pins (enable PWM pins), then eth0 will gone again.

When I disable PWM on Jetson-IO and return all pins to theirs default state, ethernet also doesn’t work. So, I need to wait an L4T update if I wanna use Ethernet :)

Sorry for my bad English.

hello EldarK,

may I also know which pin you’re configured to reproduce the issue?

I was enabled pwm1 (33 pin) and pwm8(32 pin).

My configuration on this screen.

hello EldarK,

please refer to this similar issue, Topic 169753, by using to configure pin-33 as PWM,
could you please also share the value of this register 0x02440020 by setting pin-33 as PWM.

Can you provide me any command or guide to read value of this register?

hello EldarK,

you can use devmem utility to read this register value.
for example, # devmem [I2C Address] [WIDTH]