eth0 not working on custom carrier with PCIe MB1 config applied

I applied recommended changes to tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg in order to enable TX2 PCIe on a custom carrier. This works, TX2 now recognizes my PCIe device.

However, after this change, eth0 no longer works on the custom carrier in about 90% of boots. Maybe 1 out of 10 boots, eth0 does come up, but usually it does not, and when I try to bring it up by command, I get this error:

root@tegra-ubuntu:/home/nvidia# ip link set eth0 up
[   30.964940] eqos 2490000.ether_qos: EQOS ISO BW reservation failed
RTNETLINK answers: Cannot allocate memory

If I re-flash the stock image (reverting change to tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg), eth0 then comes up every time on the custom carrier.

eth0 does come up on the devkit carrier every time in both configurations.

Hi readonly,
Please try to disable eth_iso_enable in device tree

- nvidia,eth_iso_enable = <1>; /*1=enable, 0=disable */
+ nvidia,eth_iso_enable = <0>; /*1=enable, 0=disable */

Reference link:
https://devtalk.nvidia.com/default/topic/1001443/jetson-tx2/extlinux-conf-fdt-no-longer-used-for-dtb-file-specification-/post/5131675/#5131675

Hi,

This will be fixed automatically when your EMC issue fixed.
https://devtalk.nvidia.com/default/topic/1009443/jetson-tx2/slow-memory-copy-performance-how-to-set-emc-clock-/

Regards,