Ethernet issue on Jetson TX2 ( Energy Efficient Ethernet )

Hi,

having said below comment in https://elinux.org/Jetson/FAQ/BSP

The Broadcom Ethernet PHY used on Jetson TX2 has issue when Energy-Efficient Ethernet(EEE)
 enabled. Apply patch and enable CONFIG_EQOS_DISABLE_EEE kernel config, or user may meet some
 kinds of Ethernet issue (long delay, link down, transfer stuck or something else).
 The patch is merged in L4T R32.3.

I need to know whether EEE is disabled or enabled by default in L4T R32.3 !!

can you confirm by default status of EEE ??

Thanks in advance

No, EEE is not enabled by default.

Please add CONFIG_EQOS_DISABLE_EEE in tegra_defconfig and rebuilt the kernel.

Thank you for your reply.

I’m little bit confused,
you are saying EEE is not enabled by default. That’s what I wanted. But also you said add CONFIG_EQOS_DISABLE_EEE n rebuild it .
you mean to say if i want to enable it i have to define it and rebuild it ??

But the link/pathch(https://elinux.org/Jetson/FAQ/BSP) says contradict of what you said in second line of your comment.

Please confirm.

Thank you

Sorry. didn’t get your question in the beginning.

I just checked the source code. However, only see the Kconfig defined the “CONFIG_EQOS_DISABLE_EEE” with default n. So actually EEE seems still enabled by default.

You could check kernel/nvidia/drivers/net/ethernet/nvidia/eqos/Kconfig and whether bcm89610_disable_eee_adv is being called in “kernel-4.9/drivers/net/phy/broadcom.c” to make sure.