Ethernet & UART over USB OTG cable

We run a TX2 on a ConnectTech Orbitty board.

For the headless setup, I want to configure the Jetson over UART (https://docs.nvidia.com/jetson/l4t/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E0DB0HA). I do not want use the hardware UARTs for this (ttyS0 and ttyTHS2), because those are connected to other parts of the system, I have thus disabled boot messages on ttyS0 as described here: http://connecttech.com/resource-center/kdb347-reassigning-disable-serial-debug-connect-tech-tx1-carriers/.

Which tty do I have to set for the oem setup tool so I can ues the virtual UART over the OTG cable?

And, secondly, what do I have to do on the host or Jetson after flashing so that the virtual UART and ethernet devices actually show up on my host? I tried plugging and re-plugging the OTG cable, but it just does not show up. Only thing I got to work was using the WiFi after manually confguring it from the Jetson GUI. I’d much prefer using the ethernet USB bridge.

hello jonathanhtxp3,

please refer to Disable Console over UART chapter to modify the UART settings.
may I also know which port you’re connected OTG cable for virtual UART ?
thanks

I have already done that.

from the Jetson OTG USB port, to some USB A port on my host machine.

hello jonathanhtxp3,

please contact with ConnectTech for further support.
thanks