Ethernet unavailable on bootup, shows up 5 min later.

Here’s the rundown.

  • New board, R19: ethernet seems to be working fine.

  • Flash to R21.4: ethernet seems to be working fine.

  • mini-pcie, Intel 7260HMW is installed, but not working

  • run: sudo apt-get install linux-firmware

  • mini-pcie working

  • reboot

  • ethernet not working

  • reflash R21.4

  • ethernet not working

  • write custom networking file:
    auto eth0
    iface eth0 inet dhcp

  • reboot

    • lights on ethernet port
    • long wait on boot for network:
      • lights off on ethernet port
        “Waiting for network configuration…”
        “Waiting up to 60 more seconds for network configuration”
    • finish booting with no ethernet
    • 5 min later ethernet lights are on and ethernet is connected after wifi fails to connect.
  • power off

  • remove mini-pcie

  • boot

  • still having long time out on ethernet with lights off, but ethernet becomes available shortly after see Unity log in.

Any thoughts?

Hi csherstan,

Is your network card OK? I mean does it have any fault that might interrupt on-board Ethernet port.
Could you test with anyother mPCIE card available with you.

I tested with my “Qualcomm Atheros AR9485 Wireless Network Adapter” and on-board Ethernet was working fine on reboots.

On installing basic firmware using linux-firmware, I could see the card in the “lspci” list.

root@tegra-ubuntu:~# lspci
00:00.0 PCI bridge: NVIDIA Corporation Device 0e12 (rev a1)
01:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
02:00.0 PCI bridge: NVIDIA Corporation Device 0e13 (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

Also do you have a custom kernel which have the driver enabled for the card? As the kernel that comes with the board / any release does not have the drivers enabled for external cards.

Mohit Sharma

It really sounds like delays are from working hardware in which the wireless is simply timing out and is the primary network source. Waiting for configuration says a DHCP request has gone out but nobody has yet answered.

Here’s a thread talking about the issue for Ubuntu in general:

The message about waiting and the actual wait is from “sleep” in:


The gist of the messages I looked at say the interfaces in /etc/network/interfaces are interfaces the system is saying should be mandatory at startup, and those interfaces use the sleep messages in failsafe.conf. Thus the sleep messages could be commented out in failsafe.conf to stop the boot delay, although in reality the non-mandatory interface (wireless for example) should not have been configured as mandatory in the first place.

A good question for comparison for working networking and non-working networking is “how was the device configured” (e.g., the GUI config, and what menus/options were chosen) and “were any other packages such as networkmanager added”?

Thanks for the reply.

I have removed the pcie card and the problems persist.
I have also looked at the failsafe.conf file and feel that the appropriate response is not to simply comment out the sleeps, as some have suggested on the internet. For some reason the DHCP request is taking a really long time. I did use the networkmanager gui to configure the wifi, so perhaps that has altered something? However, I did a reflash and still saw the problem.

I think that I really should not be adding the eth0 entry to my /etc/network/interfaces file, it shouldn’t be required at boot. However, if I do not add an entry then my ethernet never becomes active.

Network manager would alter configuration for both wired and wireless, and wired configuration would remain changed even if the mini-PCIe is removed.

What’s in your /etc/network/interfaces file and /etc/network/interfaces.d/ directory? This would be good to know on both your system and the other reply which had a working setup for that mini-PCIe.

There are options related to whether an interface is mandatory and waits, or if it is allowed to go on without a response from DHCP (I’d have to research it for exact config). This difference between your setup and the working setup is probably key to fixing it. I personally just use a static config on wired, and no wireless, so I completely avoid DHCP issues.

Often the reason why DHCP does not respond is an issue of router and not an issue of the wireless or wired NIC sending out the request. Many routers have a limited number of devices they’ll respond to, or security requires explicitly naming an allowed MAC address, or a certain protocol is required, so on. If you have access to your router’s logs you can see what happens as a request hits it from both a working device like your PC and the one that fails.