Every driver above 304.64 has broken brightness control in KDE

Hi,

When I log into KDE on any driver above 304.64 the brightness is two values below the brightest, when I try to adjust the brightness with my FN - Brightness UP key combo it flashes up to the brightest setting for a second then back down to the two values below it. I have tried multiple driver versions above 304.64 and all of them have the same problem. Following are install details, if further information is needed I will post it.

Dist: Debian Testing 7.0
KDE: 4.8.4
Computer: Toshiba Qosimo (Laptop)
Nvidia version that works: 295.71 and 304.64
Nvidia versions that do not: 310.32, 310.40, 313.09 beta and 313.18 beta

Follow up, I just tried 304.84 figuring a minor version change wouldn’t have the same problem. It’s does. So this broke between 304.64 and 304.84. I figure that should make it easy to track down. Also 304.84 seems to break ttys too I switch to them and they are blank… Only 304.84 does this.

See also:

https://devtalk.nvidia.com/default/topic/523904/?comment=3722546
https://devtalk.nvidia.com/default/topic/527209/?comment=3731252

Still not working as of 310.44 trying acpi_backlight=legacy and acpi_backlight=vendor in my kernel lines did not help. Stuck on 304.64. Apparently it’s not just KDE that has these issues either.

See: https://devtalk.nvidia.com/default/topic/539462/linux/-nvidia-319-12-brightness-controls-not-working-on-laptop-ubuntu-13-03-/

In my case, with KDE 4.10.2, brightness control is working again.

(driver 319.12 beta).

I can try 319.12 later but I am pretty sure I will encounter the same bug there, my brightness controls still work they just don’t go to the highest level it’s very annoying. I am worried 4.10 will not fixes it for me either as it seems to be a different bug. Upgrading to 4.10 is also hard for me as it’s not in my distros repo.

319.12 Beta still has the same problem.

319.17 still broken. Will keep trying new drivers and posting here until it’s fixed.

kittyofthebox, Please provide nvidia bug report. Is this happening on your same laptop with other OS like Ubuntu , Fedora… ?

Filed Bug 1357799 to track this issue.