ExaGear Desktop Released!

Its finally out guys!
http://eltechs.com/product/exagear-desktop/

(insert more info, but just go to the website)

With Grinch 19.3.6 all of the listed requirements are met on the Jetson board.
I have purchased this and should be able to test it out tomorrow sometime once I get the email back.

Hi, any review/experiences would be appreciated.
Purchased it as well but I am wondering if I should wait for the next official Ubuntu-release or try to update the kernel as provided in the other thread.

I got my key early this morning and had just enough time to install it and try out one application.
When you purchase the software they will send you an email with a link to the archive package and a license file.
You just unpack the archive and copy the license file inside the folder.
Then you go in with a terminal and just run the setup.
They provide manual install instructions, but the auto setup actually installs everything correctly on the first go (at least for me on the Ubuntu 14.04 Jetson board). This was pretty shocking that it worked automatically finding all of the packages.

After that it creates a new file system area in opt/exagear or something like that where the guest ubuntu lives.
Then from a command line anywhere you just type “exagear” and it takes you into the x86 command line.

I had a chance to test out one application that might fit into the typical category that a business/eng person might want to run on their linux tablet. I ran from that command line “sudo apt-get install libxrender1:i386 …” to install needed i386 packages for Eagle PCB (needs about 6 of these on Ubuntu 14.04, same procedure as on x86_x64 needing i386 packages). Then I already had the .run file in my downloads directory.

I could then navigate to my downloads directory, (anywhere on the Jetson’s storage space) and just run the installer as long as I was still in the x86 command line.
After some time the GUI install came up and it installed just like on my x86 machines. Then I could navigate into the exagear/opt/eaglepcb-versionNumber/bin and run the executable and the full GUI app would run as normal. I could open PCB and SCH files and they displayed on screen properly.
You could then put a shortcut on your desktop to run the exagear command line then run the Eagle app and you wouldn’t know the difference between the Jetson and an x86 next to it (if same software) except the Jetson is slower than my usual intel K series 4GHZ+ overclocked I5 machines at home.

I don’t have a slow intel CPU for comparison but the Jetson did run this kinda slow. But this would be suitable for say quick PCB edits or viewing a PCB on a tablet machine without dragging an x86 machine over, etc. There are some more apps I want to test but so far it was easier to use then I expected and it just worked. Just don’t expect graphics intensive programs to run very fast (at least out of the box).

Some things that I might test later this week:
QT online installer for linux (can compare this to the ARM version I compiled natively)
Calibre Ebook which is x86 only for linux
Can try running steam and some low graphics linux games for laughs

If I install wine and try that out then maybe I could try running the following windows only stuff:
IAREW
Notepad++
emIDE (windows only for now)
My Hantek oscilloscope application
Some install thing at work that generates project files compiled with VS2010

I have done a pretty good job of transitioning over to using software that is available on Linux and/or that is source available and my mind is going blank right now but I can take some more suggestions for stuff to test out.

Mind giving Limelight a try?

Do you think a decent 3d acceleration could be achieved with this? I’d like to use it for Steam as well if I were to purchase it.

I believe WINE would be a prime candidate as there is no way to run it natively on ARM obviously.
There, QEMU is pretty slow indeed…

Hi Bill, the auto-setup worked fine indeed. Could you give me some more info how to get the package manager apt-get to work in the exagear x368 environment? i got this error when trying to search/install a package:
" ExaGear itself does not support running SUID or SGID binaries,
they must be started using the binfmt_misc wrapper.
Please see the user manual for the details."
How do i configure the “binfmt_misc wrapper”, i cant find instructions in the manual.
thx.

Hi xRoyx,
Please read here:
https://devtalk.nvidia.com/default/topic/771159/jetson-tk1-run-x86-code-in-a-vm/
Install latest grinch kernel which has binfmt support and it will work.

Ok, i will try that, thank you peba.
I just ordered another jetson tk1. I will give it another try on that one.
I asked exagear if the licence key can used on the new device:
"Yes you can but with limitations. You should follow the rules. You should uninstall ExaGear from old device first and then install on new device. Also you can do that only twice i.e. you can use not more than 3 device with one key.
Thx peba.

Hm, I did install the module binfmt_misc via menuconfig etc.
And it shows in lsmod:

ubuntu@tegra-ubuntu:~$ lsmod
Module                  Size  Used by
parport_pc             14847  0 
ppdev                   7755  0 
lp                      6829  0 
parport                16565  3 lp,ppdev,parport_pc
nvhost_vi               2908  0 
binfmt_misc             5929  0

And I installed exagear which worked fine, but I, too get that error message:

ubuntu@tegra-ubuntu:~$ sudo lsmod
ExaGear itself does not support running SUID or SGID binaries,
they must be started using the binfmt_misc wrapper.
Please see the user manual for the details.

I read that it must be mounted, but the normal approach fails:

sudo mount -t binfmt_misc none /proc/sys/fs/binfmt_misc
mount: mount point /proc/sys/fs/binfmt_misc does not exist

I cant create that dir in /proc/… either.
What I can do is mounting it just somewhere:

ubuntu@tegra-ubuntu:~$ sudo mount -t binfmt_misc none bindir/
ubuntu@tegra-ubuntu:~$ lsmod
Module                  Size  Used by
binfmt_misc             5929  1

But still the error in exagears remains :(

Does it not work if compiled as a module instead of fixed into the kernel?
Any ideas would be greatly appreciated…
Thanks,
Martin

@Martin:
Why do you not use grinch kernel 19.3.7. This just works with exagear.
There are several kernel options for binfmt_misc support, it might be
you just miss one of this options.

Hm, yes. I might try that. But flashing is a bit of an effort here (all my set ups are ARM based…) and I have some other modules compiled anyway. Mostly Acorn Archimedes FIle Systems (ADFS).
I dont know if there is enough general interest in this to inclucde it in the grinch kernel?
Also I kind of missed out on 21.1 Linux. This would be an option too I guess :)

Only on New Year Holidays buy ExaGear Desktop for $10. A good gift for geeks ;) 
Just for you, up to 10 January inclusive !!! We Wish You a Merry Christmas!