Exception: The nvidia driver version installed with this OS does not give good results for reduction

ERROR IS :
Exception: The nvidia driver version installed with this OS does not give good results for reduction.Installing the nvidia driver available on the same download page as the cuda package will fix the problem: http://developer.nvidia.com/cuda-downloads

I followed the package manager installation using cuda-repo-ubuntu1604-10-1-local-10.1.168-418.67_1.0-1_amd64.deb

using ubuntu 16.04

nvidia-smi gives the following, so 418.67 is installed as the version, which is the version in the repo name. Can anybody please help resolve this error? Thanks.

Wed Jul 3 08:00:00 2019
±----------------------------------------------------------------------------+
| NVIDIA-SMI 418.67 Driver Version: 418.67 CUDA Version: 10.1 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 108… Off | 00000000:04:00.0 Off | N/A |
| 31% 47C P0 65W / 250W | 0MiB / 11177MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 108… Off | 00000000:05:00.0 Off | N/A |
| 27% 44C P0 63W / 250W | 0MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 2 GeForce GTX 108… Off | 00000000:08:00.0 Off | N/A |
| 22% 39C P0 61W / 250W | 0MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 3 GeForce GTX 108… Off | 00000000:09:00.0 Off | N/A |
| 28% 43C P0 58W / 250W | 0MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

If you googled for that error text, you will find other descriptions of it. It is apparently coming from Theano. Your post would be a lot clearer if you mentioned the application that the error is coming from.

Theano isn’t really maintained anymore:

http://deeplearning.net/software/theano/NEWS.html
https://www.i-programmer.info/news/105-artificial-intelligence/11183-theano-to-step-down-after-version-10.html

My guess would be that theano is inspecting your driver version. If it doesn’t recognize it (it really could not recognize versions of drivers released in the last ~1.5 years, since it is no longer maintained) my guess would be that it emits that error message.

I doubt there is anything you can do about it (unless you want to modify the Theano source code yourself), and I doubt you should be concerned about it if you have a recent GPU driver installed.

Perhaps the best advice is to stop using Theano.