Experienced a pretty slow starting up in View app

hello everyone~ I have experienced a pretty slow starting up in View app,it took more than 2 minutes , I’ve tried to increase the shader cache size to 10GB,but not works.Is there any suggestion?or did anyone suffered the same situation?
https://media.discordapp.net/attachments/829740270241054751/1063684233819848704/image.png?width=535&height=468
p.s. other apps seems to be normal
create starting up in 3 seconds;

1 Like

kit_20230115_004335.log (774.1 KB)
kit_20230115_010242.log (491.1 KB)
logs

profiles

ct_2023-01-15T01-02-30.gz (46.9 MB)

Hi Zalan,
Thank you for your post. We have a very very small number of people also experiencing the same thing. Around a 2 min startup for no obvious reason. We will look at your logs to confirm. When you launch the app, are you getting just a big white app box with nothing in it ? If not can you describe exactly what you see on launch ?

We are working on a possible theory that will fix this for the next release. I know this sounds very strange, but it might be something to do with the way your router is configured.

If possible, can you try the following:

  1. Could you check to see if you have “port forwarding” enabled on your router ? If so can you try disabling.
  2. Could you try again with a vpn enabled. Any vpn is fine.
  3. Can you try any other internet connection, out of your usual place. Home, office, starbucks etc.

Please let me know your results. Thanks

Hello Richard thanks for replying,here is what I’ve tried.

  1. yes,a big white app box with nothing in it,and not responced.
    2.tried to disable the port forwarding, no help
    3.vpn-on,with global proxy, no help
    4.haven’t tried another network.

network seems not the reason since windows asks me if allow viewapp to connect the network after 2min’s launching.

I’ve launched normally once about in 4 sec : after increase the shader cache size to 10GB , but fall to 2min after that.

4.changed to another network, another device ( my laptop rtx3060), with new installation, and problem still occured.
its strange that create app is ok in both platform

Hi there,
It is strange that the vpn didn’t help. That seems to be the fix for now. So now you have two machines not starting properly ?

Same here for View 2022.3.3 (Non responsive for 2.45 MIN (everytime)) Went back to earlier version 2022.2.1 started right away.

Hi Glen,
So the older version works normally but the new version is delayed all the time ? Are you on a corporate vpn ? Does vpn make any difference ? What about if you log in from home ? And it is only with View ?

yes,2 machines having the same problem,maybe its the network but vpn didn’t work~and same with Glen situation 2022.2.1 works well~

You are saying the VPN does not help. Are you working from home or working inside a corporate firewall at an office ?

This post was flagged by the community and is temporarily hidden.

I have some good news. We are pretty sure we have identied the issue and I would like you to test a very simple fix to see it is helps.

  1. watch the video for an overview video below
  2. open “omni.app.view.bat” in notepad
  3. Add “–/exts/omni.kit.splash/enabled=0” to the end of the command line

It should look like this when done:
echo off
setlocal
call “%~dp0kit\kit.exe” “%%~dp0apps/omni.app.view.kit” %* –/exts/omni.kit.splash/enabled=0

So try that and it should work immediately.
The good news is that we are close to our next release and the fix should be in for that automatically.