Explorer.exe Constant CPU Usage with K120Q GRID vGPU

Our XenDesktop 7.6 image (Win7 32-bit) running on XenServer 6.5 SP1 with NVIDIA K1 GPU (K120Q) is experiencing an issue where explorer.exe process constantly occupies 5-10% CPU and the process hangs for a fraction of a second every 2 seconds or so. This causes the start menu and other explorer functions to appear to “lag” and users complain their session is slow. After some time (usually 1-2 hours), Explorer goes back to normal. Disabling the NVIDIA card/driver gets rid of the issue and I can confirm with Process Monitor/Explorer that it has something to do with the NVIDIA GPU. I’ve done some dumps with procdump I’m happy to share, but unable to decipher much else myself. I’ve tried multiple versions of the driver as well - the current one we use is 348.27.

The issue does not occur if we log directly in to the console of the VDA (for example, in XenCenter). It only happens when logging in via Citrix Receiver, from both Wyse Xenith Pro 2 and Windows desktops.

Can anyone confirm if their own XenDesktop + K120Q setup exhibits the same CPU usage on explorer.exe?

We’ve seen a similar issue where it’s linked to the lossless indicator in the system tray.

Disabling the lossless indicator (by removing the .exe) appears to resolve the issue. What we don’tyet know is the root cause or trigger condition to cause it.

Take a look at the lossless indicator process and see what happens when you terminate it.

Following up with Citrix, they advised us of some issues fixed in XD 7.6 FP3 - if using XD7.6 it’s probably worth checking this in http://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-whats-new/feature-pack-3–vda-for-desktop-os—fixed-issues.html

In particular the lossless indicator issue indicated by Jason is likely to be:

On VDAs with HDX 3D Pro enabled, the lossless indicator taskbar icon (for LLIndicator.exe) might fail to indicate the lossless state and might not respond when right-clicked.

VDA 7.6.300 is the same as the VDA that comes with 7.7 and so upgrading to 7.7 should also include the fix as per 7.6 FP3

It’s definitely worth reading the other issues if using XD7.6 in case you encounter/suspect them - the #LC2931 is the bug number and reference that you can use to discuss with Citrix support. I believe any customer of Citrix without support can raise a ticket on a known/acknowledged issue that will be refunded if a known issue.


The issue described by phite is different from the one you describe.
#LC2931: This was reported by me, when right clicking on the LLIndicator there was no popup to select LossLess mode.

The issue with Explorer.exe consuming 5%-10% CPU is still visible in FP3. If you look in ProcMon it is continuously querying the registry for some NVidia keys.

Hi RKossen,

thank you that’s useful to know. I will go hunting and see if we can track this one down… thanks for the information, very useful!


Hi RKossen,

I’ve checked with both Citrix and the architect who reported an explorer.exe cpu issue.

The LC2931 fix addressed the lossless indicator not displaying but also included other changes to address a CPU consumption issue (the LC2391 is a reference for the customer reported bug and sometimes contains other internally discovered issues I am told - but only reported ones documented)

Our architect has retested with FP3 and found that the explorer.exe cpu issue he has is resolved by FP3. So it sounds like some experiencing it will find it fixed. And it sounds like there must be another issue that we haven’t got in our internal systems yet (or I just can’t find it). Have you reported what you are seeing with procmon to Citrix or NVIDIA and do you have reference numbers? If so I will chase the reference numbers.

Best wishes,

Thanks for all the responses guys. I guess I forgot to turn on notifications to this thread, so I never came back to respond.

I can also confirm that the issue is tied to LLIndicator.exe for us (the Lossless Indicator). However, we recently updated our VDA to 7.6.3 (FP3) and the issue is still there. I can easily confirm by using Process Explorer to suspend LLIndicator.exe (you can’t kill it because it just re-launches immediately) and Explorer.exe CPU usage immediately goes from 5-9% down to 0%. We performed an upgrade from 7.6 to 7.6.3 on our image - not sure if it makes a difference or not versus a clean install.

I’m not sure if there is a method for removing LLIndicator.exe via GPO/Registry/CitrixPolicy, since we have no need for it - our users don’t need to know the lossless state and have no control over the setting.

I’ve not yet tried 7.7, but as noted it should be almost identical to 7.6.3.

It may be worth trying a clean VDA install, just to check if that cleans it up.

If it does we can let Citrix know hte upgrade process isn’t fixing it.