External DELL screen is not working with Ubuntu 21.04 on Thinkpad


I am trying to connect my Lenovo, Thinkpad laptop with my DELL external screen via HDMI . Either the external screen blinks and shows the colors in very bad quality or it doesn’t connect all with “No HDMI signal from your device” message. Laptop runs Ubuntu 21.04.

My external screen works fine via the same HDMI cable with another laptop. Moreover, my Levono, Thinkpad also works fine with another external screen via HDMI .

I have tried so many proposals found in the forums here but nothing helped. Some of the things I tried was disabling secure boot, editing /lib/systemd/system/gdm3.service , restarting gdm3 , installing nvidia-driver-435 , checking about blacklist-nvidia.conf files, running update-initramfs -u etc etc but nothing worked.

Moreover, I am not sure whether it’s related but sometimes when I boot my system, I can see a message Nvidia GPU not detected. It is not shown every time I boot though, just sometimes.

Do you maybe have any idea what is happening? Thanks in advance!

~ $ xrandr

Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      60.03  
   1280x800      59.99  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  

~ $ sudo lshw -C display

       description: VGA compatible controller
       product: UHD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:2f0-2ef iomemory:2f0-2ef irq:158 memory:2ffa000000-2ffaffffff memory:2fa0000000-2fafffffff ioport:e000(size=64) memory:c0000-dffff

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thank you for your reply! Here is the log file.

nvidia-bug-report.log.gz (122.9 KB)

There’s no nvidia gpu built into your laptop, only the “Extreme” models have one.

So, it is not a nvidia problem?

You don’t have anything nvidia in that notebook, so it can’t be an nvidia problem.