External monitor blinking nvidia gtx 960m ubuntu 20.04

I have recently switched to Ubuntu 20.04 from Windows 10. I never had a problem using an AOC external monitor I have. Now the image on the AOC monitor is blinking, sometimes it turns black for 1 second or so. I am using HDMI port. I have tried another monitor and I have the same issue but if I connect to a TV or projector everything is ok.
nvidia-bug-report.log (3.0 MB)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thank you for your quick response. I updated the post.

All your monitors are connected to the intel igpu, the nvidia gpu having no outputs. The modesetting driver seems to be having a hard time keeping up the hdmi connection, renegotiating transfer speeds:

[    29.145] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    29.267] randr: falling back to unsynchronized pixmap sharing
[    29.516] randr: falling back to unsynchronized pixmap sharing
[    29.704] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    32.154] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    33.834] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    43.437] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    58.227] (--) modeset(G0): HDMI max TMDS frequency 250000KHz
[    58.479] (--) modeset(G0): HDMI max TMDS frequency 250000KHz

I suspect simply a broken cable, the TV and projector that worked probably being 1080p so needing only about 150MHz pixelclock which just worked. The Windows driver might be having different thresholds before renegotiation triggers.
Did you already try swapping cable? How long is it?

Yes, I have tried 4 different cables. Same issue with all of them. They all are 1-2 meters long. Those 4 cables work fine if I plug them into another laptop to the same monitor.

Doing some research, this seems to be a general bug in the i915 driver with the hdmi connections on intel skylake cpus i7-6xxx:
For other people running into this the solution was to use the DisplayPort instead

Don’t know if that bug has been fixed meanwhile since the bug report is open. As a first measure, please upgrade to the hwe kernel 5.11:

Upgraded to kernel 5.13.0-27-generic. Still same issue. My laptop doesn’t have DisplayPort. It’s an Asus gl552vw.

Here’s the corresponding ubuntu bug report:
looks like not much been found to fix it so far.

1 Like

So finally the solution was to downgrade to Ubuntu 18.04. They broke something with 20.04 and it seems it has not been fixed yet. Thank you for your help.

Yes, the bug was introduced in around kernel 4.17, 18.04 has 4.15 as GA kernel. NB: The hwe kernel of 18.04 is also 5.4, so you shouldn’t upgrade that.

1 Like

nvidia-bug-report.log.gz (338.0 KB)

Having similar problems with gtx 1650. sending my log file just for your information to resolve the issue

@rvarlikli please set kernel parameter

I did. did not worked. sending screenshots and logs for your information

Not allowed more than 3 replies so updating here
I did and the problem extended to laptop screen

sending how my screen look like

That rather looks like defective video memory. Does it also appear if you switch to nvidia as primary gpu using prime-select?

it is what i have at the moment. laptop screen is good but external always as attached

Please switch to performance mode and check if after rebooting the effect on the external monitor is gone or extends to the internal screen.