External monitor freezes when using dedicated GPU

In my configuration, the laptop display is off, and the lid is closed (nothing happens if I open it either, since it’s controlled by xrandr) but I will keep this in mind.

New development today is that both external monitors just go completely black for about 10 seconds about once per minute (as if I’d unplugged/replugged my dock).

1 Like

which driver are you using?

I hope this external screen freezing is the same as my freezing and gets fixed!

1 Like

yes, it does freeze in fullscreen and matching max resolution. try:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia openarena
you can also leave it on external screen, switch to other display and try work with other apps for a while - it will freeze external one, while game will be actually running with no issues, so you can switch back to it and move your character.
Also freezes when running fullscreen game via Wine (tested Zero-K)

1 Like

@mxmilkiib I see that you write that “the hangs and freezes were greatly reduced by also pinning the Intel side of things to max performance”.
Is there anything from your research that you think could be helpful?

I’m having similar issues on my Arch system (535.113.01-8). I found that the issue only occurs if both:

  • External monitor is used
  • Hybrid graphics is enabled (Optimus)

Changing to only discrete graphics seems like an ok workaround for now, but ideally I’d want to use hybrid graphics.

Thank you so much, this seems to have worked for me. I am trying to reproduce the freezing, and I am not experiencing it anymore. However, now everything seems to be zoomed in, and the resolution is fine, as is the scaling

@tsikas80s can you describe what you did to make it work? You mean ‘changing to only discrete graphics’?

From the BIOS i disabled the Hybrid graphics (Optimus)
6 hours now with no freeze :)

@cbg @tsikas80s
Great that disabling hybrid graphics worked for you. Could you provide the steps for doing it? I assume that you are using a Nvidia GPU (I am using RTX 4070) if that’s true I hope I have the same opinions.

My BIOS looks like this:

And I can’t see any option for hybrid graphics.
Any tips?

I can now report i had some hours without freeze.
I was using
sudo prime-select on-demand
with the freezes, and
sudo prime-select nvidia
without any problems (yet).

All with 545.23.06.

Mine (MSI Vector) looks exactly the same. I have not been able to find anything similar to discrete or hybrid graphics :(

In my bios i was not able to disable hybrid graphics. There is a way to show more options in MSI BIOS, I think by pressing: RIGHT SHIFT, RIGHT CTRL, LEFT ALT, F2. Might be something different.
I used Optimus-manager to change to discrete only. This can be only used in Arch/Manjaro systems apparently, but I bet there should be a way to change to discrete only in most distros.

Ok, trying to follow your case, I switched to Performance Mode


And everything seems to work fine. Also, the NVIDIA Settings dialog is populated with a lot of things that I never saw before… maybe this is the trick!! @Spange you should try as well!
I don’t mind a bit of extra power usage (which I assume will be attached to this mode) if it works. I hope it doesn’t get noisy though.

Edit 1: I confirm this works with my home and office external monitors. I was also able to upgrade to latest available driver (545). This is the output of apt list --installed | grep nvidia-driver :
nvidia-driver-545/jammy,now 545.23.06-0ubuntu0~gpu22.04.3 amd64 [installed]
So, I am not having freezes anymore. I do hope this gets fixed soon though…

1 Like

Excellent that it worked like this for you. I’ve been trying to achieve it the same way as you, but the PRIME profiles tab was missing for me. I think this solution will work for most. Hopefully we can get hybrid graphics fixed aswell somehow.

@Spange The Ubuntu repo only contains drivers 525 and 535, the packages named 510, 515 etc are just “transitional packages” for updating reasons really installing the 525 driver.

I confirm, max performance mode prevents freezing with glgears use case, I’ll keep an eye on other use cases.

…And I still expect Nvidia team to fix it, because it almost triples power consumption.

Here’s how it looks on Debian:

Does using nvidia-smi -lgc instead of using max performance also work? i.e.
nvidia-smi -lgc 600,2100
should help with the power consumption. at least a bit.

Thanks, @j22gim!
I went into nvidia-settings and selected Performance mode I also Prefer Maximum Performancesugested by @ursom
In fact, I also upgraded to 545 (I’ve been using 510 which @generix says is actually 525)

No freeze for 10 mins now 🤞
I’ll keep you updated!

1 Like