F24 4k HDMI 2.0 367.35 System Freeze

Upgraded to F24 and installed latest version of drivers. All things work but will get random freezes. Once this freeze occurs I have to do a hard reset. Upon reboot xorg does not start and the networking goes down so I cannot troubleshoot remotely. Everything local on the system is unresponsive, even changing virtual terminals

GeForce GTX 970
HDMI 2.0
Samsung Curved 40" 4k (JU6700)
Fedora 24
Nvidia Driver Version: 367.35

Just to be clear, this was a clean install. Enabled rpmfusion, install akmod-nvidia reboot and was working fine. Froze and now won’t come back up. Getting XID errors in dmesg

Did another clean install of Fedora and tried the driver supplied from the website with the same result. This time I cannot get gdm to start at all. I get text and network up until starting gnome, then XID errors and my television turns black. After that network is down and I have to hard reset.

Linux Kernel 4.6.4-301.fc24.x86_64

I am still seeing the issue. I did a clean install of F24 x86_64,
installed nvidia driver from rpmfusion. I was testing sddm w/ KDE
this time. Has been working for a couple weeks. This morning in
google chrome, it started freaking out and flashing then my system
locked. I reboot and now cannot get into X anymore. The system will
boot into runlevel 3, but whenever I do normal graphical boot it
starts to load, I can ssh - then it hard locks and kills network, last
message is the following:

NVRM: Xid (PCI:0000:01:00): 62, 12fe(3990) 00000000 00000000