F24 permission problems?

After installing NVIDIA-Linux-x86_64-304.132 driver on Fedora 24 with 4.8.4-200 kernel I can’t start any GLX application as a normal user. This user is added to “video” group. There are no problems however when I use su or sudo.

glxinfo returns :

$ glxinfo
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  87
  Current serial number in output stream:  88

I tried disabling SELinux but that didn’t help.

Does the problem go away if you start the X server with the +iglx option or add

Option "AllowIndirectGLXProtocol"

to xorg.conf?

I managed to reproduce this and it’s being tracked in bug 1835736.

I think I have a similar problem. No direct rendering unless root. Same Nvidia driver on Linux Mint 17.3: 304.132-0ubuntu0.14.04.2
Graphic card: GeForce Go 7300. The output of glxinfo as a standard user is:

~ $ glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

And as root:

# glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

The option “AllowIndirectGLXProtocol” enabled in the xorg.conf didn’t make any difference.

Any updates regarding the progress to resolving this bug?

I’m on F24/F25 - everything works perfectly:

$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

... skipped ...

$ cat /etc/selinux/config 

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=enforcing
# SELINUXTYPE= can take one of these three values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected. 
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

Interesting. Great it works. But, what is your Nvidia driver version? My concerns are with the 304.132 version. I read that some people downgraded to 304.131.

Oh, sorry, I’m on 375.26.

304.134 fixes the issue

https://devtalk.nvidia.com/default/topic/981836

Good to know! Thanks for the info about 304.134

I was testing the new driver 304.134. Now graphics and nvidia-settings working flawlessly. Thanks!