Factory Of The Future Simulation: TensorRT Error!

I also had some issues about cuda malloc and going to cuda 11 solved it if I remember correctly
this is my output :

thoth@bigC:~$ nvidia-smi
Thu Jul 30 13:17:34 2020       
| NVIDIA-SMI 450.51.06    Driver Version: 450.51.06    CUDA Version: 11.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 970     On   | 00000000:01:00.0  On |                  N/A |
| 34%   35C    P8    20W / 200W |    388MiB /  4041MiB |      1%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A       959      G   /usr/lib/xorg/Xorg                 15MiB |
|    0   N/A  N/A      1053      G   /usr/bin/gnome-shell               49MiB |
|    0   N/A  N/A      2062      G   /usr/lib/xorg/Xorg                156MiB |
|    0   N/A  N/A      2196      G   /usr/bin/gnome-shell               88MiB |
|    0   N/A  N/A      2803      G   ...AAAAAAAAA= --shared-files       69MiB |
thoth@bigC:~$ nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85
thoth@bigC:~$ cat /usr/local/cuda/version.txt
CUDA Version 11.0.207

I solved the cuda memory issue in this post
this is how I did it :
I followed setup of isaac (SDK manager with Jetpack 4.3 + Dependency script)
Then I had to install Cuda toolkit with :

`sudo dpkg -i cuda-repo-ubuntu1804_10.0.130-1_amd64.deb`
`sudo apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub`
`sudo apt-get update`
`sudo apt-get install cuda`

Then perform post installation commands :

$export PATH=/usr/local/cuda-11.0/bin${PATH:+:${PATH}}
$ export LD_LIBRARY_PATH=/usr/local/cuda-11.0/lib64\
sudo systemctl enable nvidia-persistenced

Isaac is not willing to run on my PC :(

whats happening here???

do you have something in usr/local/cuda-11.0/ ?


i can see some folders in usr/local/cuda-11.0/ ?

I skipped some optional steps in my post, refer to the installation doc and post install doc
Maybe it is because of your gpu driver that is not 450 but I really not sure about that so check the doc.
also do you have the same output than me when you run nvcc --version ?

MY GPU Driver has also upgraded to 450 and heres my output:
Screenshot from 2020-07-31 00-56-06

I got Cuda compilation tools, release 9.1, V9.1.85 so It can also come from there.
please follow all the steps of the doc and check for any error during installation
Create a backup folder in an external storage hardware for it can be messy when you play with cuda an graphic driver, trust my experiences :)

And well I think you already know that but some steps require reboot to take effect. By the way I have cuda 10 and cuda 11 installed

HI there! Thanks for you help @Planktos. after couple of days, hard trying i am still there :{ even though my nvidia-persistenced is also enabled. everything seems as per instructions now :(

hello general,
do you still have the same error ?

yess the same malloc error and my unity simulator gets shut down?

its frustrating now

do you think if my gtx 1060 not enough to run this simulation?

No a malloc error occure when there is a memory allocation probleme so it is very unlikly that it could come from your gtx, you sould at least be able to run the simulation even if it takes longer.
Do you have the good version of unity ?
Can you run a cuda sample ? (from the cuda doc or from isaac)

yes i can run cuda samples from cuda doc :( the ones in

what about the cuda 11 sample and the isaac cuda ping pong sample ?

Meybe reinstall from zero could help because if all the samples works I really don’t know what else to do … I hope that some of the nvidia staff will have some ideas

All the bindings seem correct! its like my hundred-th time now installing everything from scratch:
I have never been disappointed like this before !!

No Nvidia official is having a look at this thread! :(