Fail to flash another APP partition with -k option

Hi Sir/Madam,

I reduce original rootfs size to 8GiB and create another APP partition in flash_t194_sdmmc.xml.
I can flash entire emmc with “sudo ./ -r jetson-xavier mmcblk0p1” and each rootfs works well. But if I use -k option to flash specific new APP partition, will fail to write new_system.img at about 7% progress. (Error: Return value 3)

I add APP_1 in and assign new rootfs image name to target_partfile. Is there any thing I miss?

Thank you!

hello JasonFan,

am I understand correctly that you would like to have two APP partitions.
could you please also attach details of the flashing process. thanks

Hi Jerry,

Yes. Actually I create three APP partitions.

  1. Modify ROOTFSSIZE to 8GiB
  2. Add APP_1, APP_2 in flash_t194_sdmmc.xml
  3. Add followings in (I think this is only for flash the specific partition)
    APP_1) target_partfile=system_1.img
    APP_2) target_partfile=system_2.img
    (system_1.img and system_2.img are that I copy from system.img)

It looks that I can flash all three APP partitions with “sudo ./ -r jetson-xavier mmcblk0p1” but can’t flash individually with the options -r -k “sudo ./ -r -k APP_1 jetson-xavier mmcblk0p1”

the flash log is as attach. (34.4 KB)

hello JasonFan,

please check the script file.
using the -k option to specify APP_1 partition should be not supported.
for example,

if [ "${target_partname}" != "" ]; then
        validatePartID target_partid target_partname $target_partname $localcfgfile;
        APP) target_partfile="${localsysfile}"; ;;

you might have a try to update the flash script to modify the partition name.
then, have another try to update APP partition.

Hi Jerry,

Thanks for your reply

I know the original doesn’t support APP_1 partition. Since the original partitions map doesn’t fit our requirements, I tried modify flash_t194_sdmmc.xml and

So that’s why I add the followings in (please see the previous post)
APP_1) target_partfile=system_1.img
APP_2) target_partfile=system_2.img

Now I can see “updated successfully”. Maybe I re-arrange the partitions to let it work.

hello JasonFan,

Maybe I re-arrange the partitions to let it work.

could you please confirm what’s the modification to get things worked.
or, please share some snippet of flash_t194_sdmmc.xml and for reference.

Hi Jerry,

The partition maps is confidential information so I can’t share it here.

After testing over and over again, the images including bootloader/kernel/rootfs that I build during at the same time, I can use these rootfs images to flash to the specific partitions that I want to flash successfully.

If these images I build at different time, it will fail at flashing.
I think it maybe related to signature but I’m not sure. do a lot of things at the same time while flashing. It would be better and more flexible to take apart build images, sign images, and flash images.