Fail to Launch NVBlox with Isaac SIM

Dear NV team,
I tried to run NVBlox with Isaac SIM by following the instructions below:

When going to step 5, it gives the errors as follows and exit finally:

2023-06-07 06:57:48 [18,498ms] [Error] [] VkResult: ERROR_DEVICE_LOST
2023-06-07 06:57:48 [18,498ms] [Error] [] submitToQueueCommon failed.
2023-06-07 06:57:48 [18,498ms] [Error] [] A GPU crash occurred. Exiting the application...
Reasons for the failure: a device lost, out of memory, or an unexpected bug.
2023-06-07 06:57:49 [19,005ms] [Error] [] VkResult: ERROR_DEVICE_LOST
2023-06-07 06:57:49 [19,005ms] [Error] [] vkWaitForFences `Preformatted text`failed for command queue.
/home/andrewli/.local/share/ov/pkg/isaac_sim-2022.2.1/ line 41: 16064 Segmentation fault      (core dumped) $python_exe "$@" $args
There was an error running python

Tried different versions of NVidia drivers, it didn’t help. For RTX 4090, what driver version can be used? Thanks.

System configuration:
OS: Ubuntu 20.04.06 LTS
CPU: Intel i9 13900K
GPU: NVidia RTX 4090
NVidia Driver version: 525.116.04
CUDA version: 12.0
docker version: 24.0.2
Python3 version: 3.8.10

vulkan issue log (23.3 KB)
Log file is attached.

Hi @andrew.li20181108 - You can find the Isaac Sim requirements here: 1. Isaac Sim Requirements — Omniverse Robotics documentation

Also, you can find the “Error_Device_Lost” related troubleshooting information here: Linux Troubleshooting — Omniverse Launcher documentation

Hi rthaker,
After loading driver 525.60.11 and selecting proper versions for other tools, NVBlox works now. Thanks a lot.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.