Fail to Open MDL Table and RPC Plant Table

I was trying to send my current Sketchup project to the Omniverse Create, but there were errors saying “Fail to Open MDL Table” & “Fail to Open RPC Plant Table”.
I have double checked the sketchup connector file and made sure the MDL &Plant Tables were downloaded

@chernoalpha36 i am just another user passing by, but would like to clarify a few things:

  • by mentioning ‘Create’, it sounds like you meant Composer. could you confirm the version of Composer you are currently using?
  • similarly, which version of the sketchup connector and sketchup itself?
  • from where did you see the error message? from the connector in sketchup or the console inside Composer?
  • could you paste the full path of the two files on disc? (wanted to double check naming conventions)

Hi @Simplychenable

  • I’m using the 2022.3.3 version of Composer
  • The Sketchup version is SketchUp Pro 2023, the connector version is 200.1.668
  • The error occured from the connector in sketchup
  • The full path of the two files is under
    C:\Users\morga\AppData\Local\ov\pkg\sketchup-connector-200.1.668\2023\plugin\materials

lets try one thing at a time - could you try upgrading to the latest composer version 2023.2.3 and see if it helps? you can find it under beta section (despite its name, it’s in fact fully functional). the most current version should have addressed a lot of the bugs since 2022.3.3.

I have updated to the newest version and it was still not working. I have also attached my Omniverse settings in SketchUp

thanks for the screenshot. before proceeding to the next test, did any file get exported at all or did the error prevented the export altogether?

the next thing we could investigate is the file from sketchup. could you try making a simple sketchup scene with one or two objects with any materials and try going through the process again and see if anything changes?

The model was imported successfully but the material was missing, which caused the whole scene to be red. I tried making a simple scene but came out with the same result.

presumably with the same error message during export? the red shader that you see in Composer is a placeholder to indicate a broken shader, most likely from the export error from the connector.

i see you currently have Do Not Use Nucleus unticked, with the local folder path that includes a question mark, which could be problematic. secondly, have you tried ticking on Use Sketchup Materials option prior to an export?

I changed the local folder path to a different location and tried Use Sketchup Materials option but still turned into the same result =(