Fail to SSH connect TX2 to rpi


Not abble to connect a pi to tx2 kit via ssh.

Set eth on pi :

cat /etc/network/interfaces
auto eth0
iface eth0 inet static

First directly connect to a laptop lts18.04
via networkmanager set: local link only.
That’s allright : works well.

Same thing on TX2 JP4.3 not working.

But setting network manager on DHCP auto and connectTX2 and RPi via a switch :it’s working…

I want a direct connecting to have an quick transmission via Rtsp and try to increase speed flow camera images.

regard’s .

there is a discrepancy in networks
versus subnet;
try gateway; or set up the static ip ap address as

Hi Andrey1984,

I have try this modify on rpi


and set on TX2 :

link local only

this work’s fine!

Test my glass to glass picam via rtsp on tx2 is around 100ms.
So no improvment with comparating setting dhcp on auto and via the switch.
( even with nice set to -20).

Thank’s you very much!


At the time of trying ssh, what do you see from the output of “ifconfig” and “route” on each unit?