Failed boot after flashing Xavier NX with Jetson 4.6

I have been attempting to flash a Xavier NX with jetpack 4.6 (L4T 23.6.1) following the quick start flashing procedure outlined here: NVIDIA Jetson Linux Developer Guide : Introduction | NVIDIA Docs
However, Once the flash has been completed successfully it will then allow me to setup the computer (setting username and password etc.) but once that is complete the computer wont boot instead showing 3 errors (Also show in attached images):

• “Failed to start Load Kernel Modules”
• “Failed to start nvpmodel service”
• “Failed to start Docker Application Container Engine”

Following other online forums I have checked the output of unname -r: 4.9.253-tegra. But I haven’t been able to solve any of the errors, enabling the computer to boot. (The device is a emmc Xavier Nx on a auvidea carrier board, it has been flashed multiple times)

Any Advice?

Thanks a lot,

Flash with jetpack4.6.3 in case a known issue on old jetpack version.

Ok, Is there a way which we can revert jetpack 4.6.3 back to 4.6 once flashed? We require jetpack 4.6 to run software which was built on L4T 32.6.1 and hasn’t worked on more recent versions.

If you insist on using jp4.6, enable an capture the full log from serial console first.

Ok, thank you. The alternative being updating the software to run on more recent versions of L4T, is this what you would recommend?

I don’t guarantee your issue would be fixed by using recent version. It is just kind of SOP when we deal with issue here. We don’t really debug on old release version.

Ok, so I have successfully flashed it with Jetpack 4.6.3. Where would you recommend I go from here? Should I revert the system to the previous version of jetpack 4.6, reflash with 4.6 and debug the flashing error or are they both bad ideas and more effort than its worth and should we be updating the software?

So does your device work fine with jp4.6.3?

If jp4.6.3 is fine, at least we prove this is not hardware problem.

Please “delete” the whole jetpack 4.6 BSP on your host. Let sdkmanager download it again, and do full flash again.

If the issue is still there , access your board with serial console as my previous post and share me the dmesg. I would also ask for further log after you dumped that log.

Ok, I will give this a go and get back to you. Thanks

So I have reflashed the board with 4.6 and am encountering the same issue again. I have attached the dmesg --follow output and the serial console boot log to this post.
dmesg–follow_Output (593 Bytes)
Serial_console_boot_log (63.9 KB)

Also, could this issue be related to the fact the fact this device has peviously had the rootfs pivoted to the NVMe following this walkthrough: Jetson Xavier NX - Run from SSD - JetsonHacks
(Not sure why that would affect Jetpack 4.6 and not 4.6.3 but thought it may be worth a mention)



Just in case you don’t realize. I need the dmesg from jetson. Not your host pc.

If you cannot dump it because your serial console cannot operate, remove the “quiet” in your Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf and reflash your board again…

After doing that, your serial log will have full log.

Also, your log is truncated in each line… please resize your terminal before dumping any log…

And yes, it looks like your device is still booting from nvme.

In case you don’t know, I guess your reflash didn’t flash anything successfully.

It is just kind of you are using some data from nvme and those things are mismatched from your kernel version. (part of files from nvme while rest of files from emmc)

Remove your nvme and reflash the whole board again with sdkmanager may bring your device back to normal.

Hi Wayne,

Thanks for all your help, I have solved and fixed the issue and am now succesfully flashing the boards. It was related to the NVMe being previously flashed. Your suggestion helped a lot.

All the best,

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.