Failed Driver Installation for P5000 on CentOS 7 with 515.43.04

Installed latest driver 515.43.04 on a CentOS 7.9 system with a Quadro P5000 installed. After installing I was getting the typical error from nvidia-smi about driver not being loaded. When I checked the log I saw this message

NVRM: The NVIDIA GPU 0000:00:0a.0 (PCI ID: 10de:1bb0)#012NVRM: installed in this system is not supported by the #012NVRM: NVIDIA 515.43.04 driver release. #012NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’#012NVRM in this release’s README.

However on that Appendix it specifically states that the P5000 - 1BB0 is supported

https://download.nvidia.com/XFree86/Linux-x86_64/515.43.04/README/supportedchips.html

I was able to install the previous driver 510.47.03 and got it working. Also, and this is a minor gripe, but if you are installing via the nvidia repo and call out a specific version of the cuda drivers it just defaults to the latest nvidia-driver in the dependencies. It’s kind of ridiculous that I can install cuda-drivers-510.47.03-1 or cuda-drivers-470.103.01-1 and the dependency called during the install is nvidia-driver-latest-515.43.04-1. You should just skip the cuda-drivers and just specify the nvidia-drivers-latest version that you want installed.