Failed initialize GLFW

Hi,

I just started working on PX2 this week. Basically I can run all sample from driveworks on PX2. But when I remotely access (ssh) to PX2 from my own desktop, I got following errors:

/usr/local/driveworks-0.2.0/bin$ ./sample_camera_tracker
nvrm_gpu: Bug 1781434 workaround enabled.
nvrm_gpu: Bug 1778448 workaround enabled.
nvrm_gpu: Bug 1780185 workaround enabled.
Program Arguments:
–video=…/./data/samples/sfm/triangulation/video_0.h264

WindowGLFW: Failed initialize GLFW
Unexpected exception:
std::exception
Terminating app.

All samples seem to have same problem. Does anyone have a solution for this? Thanks!

Hello WZhouuuu,

Could you please update DriveWorks version from 0.2.0 to 0.2.1? The DW 0.2.1 is included in DrivePX2 Beta1 PDK.
Please refer to the below link, you can download the file and you can check how to use & setup DrivePX2.
https://developer.nvidia.com/driveworks/getting-started-with-drivepx2

Thanks.

Hi SteveNV,

I’ve already updated the driveworks to 0.2.1. But the “sample” is lost from this version. And I still couldn’t initialize GLFW. Does that mean I did something wrong to flash the Tegra?

This just looks like a problem where it’s trying to open a window on your desktop and it can’t

@WZhouuuu

Have you tried X11 forwarding?

ssh -X <user>@<address>

X11 fowarding isn’t working for me I get a similar error:

WindowGLFW: Failed initialize GLFW
terminate called after throwing an instance of ‘std::exception’
what(): std::exception
Aborted (core dumped)
“”"

so I’m wondering if there is some issue with OpenGL?

Facing similar issue with driveworks 1.2 and NSIGHT ?

Any solution for this ? How can I check if I am using right version of GLFW compatible with nsight/driveworks ?

Dear ramtej.bejugam,

Could you please refer to below link for your topic?
https://developer.nvidia.com/drive/learn/tutorial-remoteOGL

Great! it worked . Just missing the setting he right environment variable as mentioned in documentation.