Failed install of code 2023.1.1

@Richard3D
I have removed the OV folder and tried installing again but this time I am installing 2023.1.1 directly and I am running into this error.

Error occurred during installation of Code: error running: ['C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../kit/kit.exe', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps/omni.code.kit', '--allow-root', '--ext-precache-mode', '--/app/settings/persistent=0', '--/app/settings/loadUserConfig=0', '--/app/enableStdoutOutput=1', '--/app/extensions/registryEnabled=1', '--/app/extensions/mkdirExtFolders=0', '--/log/flushStandardStreamOutput=1', '--/exts/omni.kit.registry.nucleus/registries/0/name="kit/default"', '--/exts/omni.kit.registry.nucleus/registries/0/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/shared"', '--/exts/omni.kit.registry.nucleus/registries/1/name="kit/sdk"', '--/exts/omni.kit.registry.nucleus/registries/1/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/sdk/${kit_version_short}/${kit_git_hash}"', "--/app/extensions/registryCacheFull='C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../extscache'", '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../exts', '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps', '--/app/extensions/parallelPullEnabled=1', '--/app/enableStdoutOutput=0', '--/app/fastShutdown=1'], code: 55, message: ""

I still don’t know how to solve the issue with connection to localhost, if you could also help with that.

Ill attach my log file here:
launcher.log (100.2 KB)

I don’t know. I think you need to fully nuke everything and start over.
Quit Launcher
go to task manager, stop all “omni” threads.
Delete the entire OV folder.
Download the cleanup tool and run this Launcher Cleanup Tool — Omniverse Utilities latest documentation (nvidia.com)
Make sure anything “omniverse” is gone from your drive

Then reinstall launcher
Inside Launcher go to the Nucleus tab and hit the green + button and make a new local nucleus service
Install USD Composer
Install Code

Hi @Richard3D

I followed your instructions as you said but am running into probably the same error.
Error occurred during installation of Code: error running: ['C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../kit/kit.exe', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps/omni.code.kit', '--allow-root', '--ext-precache-mode', '--/app/settings/persistent=0', '--/app/settings/loadUserConfig=0', '--/app/enableStdoutOutput=1', '--/app/extensions/registryEnabled=1', '--/app/extensions/mkdirExtFolders=0', '--/log/flushStandardStreamOutput=1', '--/exts/omni.kit.registry.nucleus/registries/0/name="kit/default"', '--/exts/omni.kit.registry.nucleus/registries/0/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/shared"', '--/exts/omni.kit.registry.nucleus/registries/1/name="kit/sdk"', '--/exts/omni.kit.registry.nucleus/registries/1/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/sdk/${kit_version_short}/${kit_git_hash}"', "--/app/extensions/registryCacheFull='C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../extscache'", '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../exts', '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps', '--/app/extensions/parallelPullEnabled=1', '--/app/enableStdoutOutput=0', '--/app/fastShutdown=1'], code: 55, message: ""

One thing I have noticed is that when I install 2023.1.1, the download size is only around130MB.

Do I need to install the release version (2022.3.3) first and then update to 2023.1.1? Just to test I tried that but the download is stuck on Downloading Code since the past 30mins even though the progress bar is completely filled. I am going to wait for a few more minutes but Ill attach the log file here as well.
image

launcher.log (35.9 KB)

As you had said that there was an issue connecting to Discovery Service, I’ll attach its log here as well.
logs.txt (65.5 KB)

Please advise as the issue has already taken a few days and still hasn’t been resolved for me.

@Richard3D

I cancelled my install as the install was still ongoing after an hour.
I tried installation again for 2022.3.3 and it did get installed but now the download size was 2.08GB in contrast to 1.70GB.

Following install I tried updating to 2023.1.1 but it failed again.

Error occurred during installation of Code: error running: ['C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../kit/kit.exe', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps/omni.code.kit', '--allow-root', '--ext-precache-mode', '--/app/settings/persistent=0', '--/app/settings/loadUserConfig=0', '--/app/enableStdoutOutput=1', '--/app/extensions/registryEnabled=1', '--/app/extensions/mkdirExtFolders=0', '--/log/flushStandardStreamOutput=1', '--/exts/omni.kit.registry.nucleus/registries/0/name="kit/default"', '--/exts/omni.kit.registry.nucleus/registries/0/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/shared"', '--/exts/omni.kit.registry.nucleus/registries/1/name="kit/sdk"', '--/exts/omni.kit.registry.nucleus/registries/1/url="https://ovextensionsprod.blob.core.windows.net/exts/kit/prod/sdk/${kit_version_short}/${kit_git_hash}"', "--/app/extensions/registryCacheFull='C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../extscache'", '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../exts', '--ext-folder', 'C:\\Users\\makerslab\\AppData\\Local\\ov\\pkg\\deps\\795f6abc38988ca868180636507b0118\\dev\\tools\\../../apps', '--/app/extensions/parallelPullEnabled=1', '--/app/enableStdoutOutput=0', '--/app/fastShutdown=1'], code: 55, message: ""

Ill again add my log files.

Omniverse Log:
launcher.log (59.5 KB)

Discovery Log:
logs.txt (65.5 KB)

Can you try another machine and another network ? There is something blocking you for sure. Do you have very aggressive anti-virus or firewalls ? Is this a personal machine or a corporate machine ? If you are having a discovery issue, it sounds like this is a firewall issue. Beyond this I am not sure we can help. You must try another machine, to rule out the machine and another network to rule out the network.

Please install the following and tell me pass or fail.

Install:

  1. USD Composer
  2. USD Explorer
  3. Issac Sim

You are getting this error over and over again. Why ? What are you doing to keep starting multiple installs ?

“Error: code@2023.1.1 installation is in progress already.”

Are you trying to install multiple things at once ?

Restart your computer and then before you start Omniverse go to c:/users/USER/appdata/temp/roaming/omniverse-launcher/ and delete the “cache” folder

Then install the three things above and report back. Forget Code for now. Let’s move past it.

Hi @Richard3D

Just wanted to let you know that I don’t have any temp folder under appdata.
So I am deleting cache folder the the one under this path.
C:/users/USER/appdata/roaming/omniverse-launcher.

USD Composer was already installed.
When installing USD Explorer, it got stuck on
installing omni.usd explorer.warmum.bat for quite a while but eventually it did get installed.

For Isaac sim, its stuck on ‘downloading’ for a while now and I’m going to keep waiting to see if it crashes or not.

I want to point out that when I installed any app I was not simultaneously downloading anything. Nothing in the background nor had I queued any other app install in the launcher. I tried installing Code 2023.1.1 after USD Composer had been installed. So I cant understand how “Error: code@2023.1.1 installation is in progress already.” this error is taking place.

I am esculating this to a senior developer to find out what some of these errors mean. It seems there is an issue when you try to install Code 2023.1.1 but we need to identify the error. Can you give me the full specs of your machine and your network environment please.

Hi @Richard3D ,

Just wanted to say that Isaac Sim was still installing when I returned to then system this morning and I cancelled the installation.

My machine Specs:
Processor: 12th Gen Intel Core i7-12700KF
RAM: 32GB
GPU: NVIDIA GeForce RTX 3060 Ti
OS: Windows 11 Pro

I’ll get back to you with the network environment information.

Thank you for your private message. So you have CONFIRMED that it was in fact your firewall that was blocking the install. Thank you. Yes I was saying that.

Yes @Richard3D, it was the network firewall blocking the install.

Thanks for all the help!