Failed to acquire interface

I just installed issac gym via anaconda in ubuntu 20.04 (wsl2)

and I get this error when I tried to run the example

*** Warning: failed to preload CUDA lib
*** Warning: failed to preload PhysX libs
Importing module ‘gym_37’ (/home/ranat/issacgym/python/isaacgym/_bindings/linux-x86_64/
[Error] [carb] [Plugin:] Could not load the dynamic library from /home/ranat/issacgym/python/isaacgym/_bindings/linux-x86_64/ Error: cannot open shared object file: No such file or directory
[Warning] [carb] Potential plugin preload failed: /home/ranat/issacgym/python/isaacgym/_bindings/linux-x86_64/
Setting GYM_USD_PLUG_INFO_PATH to /home/ranat/issacgym/python/isaacgym/_bindings/linux-x86_64/usd/plugInfo.json
[Error] [carb] Failed to acquire interface: [carb::gym::Gym v0.1], by client: carb.gym.python.gym_37 (plugin name: (null))
Traceback (most recent call last):
File “”, line 59, in
gym = gymapi.acquire_gym()
RuntimeError: Failed to acquire interface: carb::gym::Gym (pluginName: nullptr)


I hope it works with wsl2 as soon as possible

1 Like

Hi @DDPG7,

Isaac Gym doesn’t support wsl2 because of driver limitations. Is using Windows a hard requirement for you?

But the standard OS for my company is Windows. I can’t connect my Linux PC to the company networks.

I also get such problem with my ubuntu 20.04, and it is not wsl. Why?

1 Like

@vmakoviychuk Is there any intention to support Isaac Gym in Windows 11 + WSL2 which has full CUDA support?


I am facing the same error in Ubuntu 20.04 LTS as well. I am just using a virtual machine to run the ubuntu.

Please, help us out with this.

1 Like

It does not work as a specification in a virtual environment.

2021年10月25日(月) 10:15 kaykay via NVIDIA Developer Forums <>:

I see people using ubuntu 20.04 also facing this as pointed out by @liming18 . So, not sure if is really due to the virtual environment. Hopefully, we hear something soon from the NVIDIA team.

The first thing to check is whether the driver version is correct. I also have the experience of changing the driver and doing well.

However, if you were using WSL etc., you will not be able to access the GPU.

2021年10月25日(月) 11:07 kaykay via NVIDIA Developer Forums <>:

Check if your PC has an Nvidia GPU

I use docker in WSL2 Ubuntu 20.04 and it finally works out.

cd isaacgym/docker

and clone the IsaacGymEnvs ,follow the
because I don’t have a display, so I set headless=True in the docker

python task=Ant headless=True
1 Like

I was also facing similar issues. Finally I figured out in my case it is because of a conflict with the SDF library in SimNet. Check it out here. Potential conflict between Isaac Gym and Modulus (SimNet)

I had the exact same error code ! After some research i found this Isaac Gym test python example error - #6 by DDPG7
After setting up the Cuda Toolkit i had no issues anymore !

This may be a niche solution, but I got this error when I tried to copy the Isaac Gym code from one machine to another - it worked on the original machine but the second machine was giving me this error, both similar machines with Ubuntu 20.04. All I did was download a fresh version from NVIDIA onto the new machine, re-ran the install and it worked.

Hi, I had the same problem with ubuntu 18.04
this could solve it.
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:‘/path to your conda/envs/your_env/lib’

docker I succeeded

I used docker WSL 2, when running the examples, the UI window is blur:

after few seconds, the window quit with Segmentation fault