"Failed to acquire modesetting permission" when use -sharevts


trying to build two 2x2 screens on NVS 810 (8 monitors connected). Found that it’s not possible with one xserver started. Started two xservers and only one of them active at a time and can be switched with ‘chvt’ command. Tried to use -sharevts option and now second server can’t be started:

[ 13895.361] (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission.
[ 13895.361] (EE) NVIDIA(0): Failing initialization of X screen
[ 13895.363] (II) UnloadModule: "nvidia"
[ 13895.363] (II) UnloadSubModule: "glxserver_nvidia"
[ 13895.363] (II) Unloading glxserver_nvidia
[ 13895.363] (II) UnloadSubModule: "wfb"
[ 13895.363] (II) UnloadSubModule: "fb"
[ 13895.363] (EE) Screen(s) found, but none have a usable configuration.
[ 13895.363] (EE)
Fatal server error:
[ 13895.363] (EE) no screens found(EE)
[ 13895.363] (EE)

Is it possible to overcome this limitation and somehow use two 2x2 screens with NVS 810 (actually I want more from two NVS810 cards in one system, but need to start from something).
Linux: Ubuntu 20.04, Driver: 515.65

I guess you should rather set up a multi-seat system using logind/loginctl, e.g. https://wiki.archlinux.org/title/Xorg_multiseat

I don’t need mouse and keyboard for any instance of X in my configuration. It must be just screens for displaying (broadcasting) some dynamic content. And reading that article I see very similar configuration for X part. Tried one tip from article - start first X instance without -sharevts, but result is the same.
I saw very same error messages when system was started with nvidia-drm.modeset=1 and then I was not able to start even first X instance with multi-monitor configuration. This seems to me like nvidia driver limitation and I want at least to find certain explanation that such configuration is not possible.
Currently I can create multiple screens configuration with one xserver started but only for four first monitors (all on one GPU of nvs810 or on nvs510). But when I try to use second GPU (more than 4 monitors) I have these obstacles with ‘modeseting permissions’.