Failed to boot TX2 evaluation board after Device Tree replacement

Hi,

I have tried to add the SPI capabilities to the device tree. I have Decompiled the device tree under /boot/ext ; added an SPI sub-node; copied back the compiled device tree file; and rebooted the board. The board never came back: no video on HDMI channel; LEDs are on correctly.

I tried to enter Recovery mode (the board is on ; while pressing the REC button I toggle the RST button and then after two seconds more release the REC buttons)- and actually I do not know what to expect (no video on HDMI). The USB recovery cable is connected to a PC running UBUNTU 16.04 - but I do not see any indication for what the USB supposed to do.

Any help will be appreciated.

Igal

Igal,

In recovery mode you won’t really see anything happening until you initiate the flash.sh script. Do you have JetPack installed?. In the JetPack/64_TX2/Linux_for_Tegra_tx2 folder there is a flash.sh. Run this script with something like this:

sudo ./flash.sh -r jetson-tx2 mmcblk0p1

And it will start the flashing of the kernel, dtb, uboot, rootfs, etc. Basically it will put it back to factory reset.

GimpMaster, hi,

Thanks for the prompt reply.

I have no visual(the HDMI provide no video out) of the board, how to you propose to flash it?

  1. I have connected a USB to serial (to connector J21, 8,9,10 pins @115200) and see garbage on the terminal screen - on an UBUNTU 16.04 PC via the minicom application.
  2. As I mentioned I have the USB (debug cable) connected to the PC but I don’t understand how the connection is established - is it only for debugging SW via NSight?)

Please advise.

Igal

To reflash a TX2 using JetPack you do not need to see anything on the HDMI.

These are the steps.

  1. Make sure you have JetPack installed
  2. Connect a USB cable to the recovery / flash USB port (USB0)
  3. Power on the devkit
  4. Hold down the recovery button, press the reset button, let go of the reset button, then finally let go of recovery button
  5. Very your Ubuntu PC is seeing the Tegra through the USB recovery port by typing lsusb and you should NOW see an Nvidia device such as:

ubuntu@ubuntu4tegra|Linux_for_Tegra_tx2> lsusb
Bus 002 Device 095: ID 0955:7721 NVidia Corp.

  1. On the Ubuntu PC, on the command line, change to the Jetpack folder and inside there go to 64_TX2/Linux_for_Tegra_tx2

  2. Finally reflash the whole thing with:

sudo ./flash.sh -r jetson-tx2 mmcblk0p1

You do not need to use the serial terminal on the Tegra TX2 while flashing at all. It does give some useful debug information. FYI the console serial is actually on J21 pins 6=Gnd, 8=TX, 10=RX

I hope this helps

GimpMaster,

I’ll run the flashing per your suggestion. Thanks.

Igal

The driver is added when you installed JetPack. Also are you sure you have the USB plugged into the proper port on the devkit? It should be plugged into the microUSB port next to the Wifi Antennas.

The USB was plugged correctly, I assume that only once the board has entered into the Factory mode only then the PC has recognized the board. Is it correct?

Anyway I have accepted your thorough answer.

Thanks,
Igal

Correct, only once you press the buttons for recovery mode do you see the nvidia device with lsusb.