Failed To Capture Video Frame - Hello AI World

At the beginning of the tutorial, Dusty talks about testing the camera. I have a Logitech C270, and when I tried to run the video-viewer command, it kept on returning “video-viewer: failed to capture video frame”. It also says no camera detected, but I know the camera works. I would really appreciate any help!

Also when I run docker/, it says V4L2_DEVICES: --device /dev/video0

1 Like

Hi @a_mac_user, can you post the console log output of the video-viewer tool when you run it? Do you launch it like video-viewer /dev/video0?

When you mentioned that you know the camera works, have you tried another program on your Jetson to view the camera feed and that worked?

I tried it with the very first Jetson Course, and it worked. I am doing a fresh install of the operating system. If I am still having errors after that, I will let you know.

I was able to do a fresh install and I think it worked. At first it gave me two fails and then it said map buffer size was less than max size, and then it gave an output.