Failed to download RequestError: self signed certificate in certificate chain

SDK Manager v1.3.1.7110 would fail during download with:

DevZone get download url failed: RequestError: self signed certificate in certificate chain.

There’s a corporate cert “switching” but I’m able to login.
No electron supported switches work. I’m able to download packages via the browser.
IT-staff actually asked me to find if there’s a way to bypass the TLS specifically(because otherwise they’d need to exclude the connection to DevZone).
Please help…


Hi ingwardrakkar,
I retested but couldn’t reproduce the issue. Could you please package and upload your ~/.nvsdkm directory for more investigation?

I guess sdkmanager uses python requests library, but I cannot pass the corporate’s certificate file to sdkmanager. I tried in bash

export SSL_CERT_FILE=myCorporateCert.pem

but not working.

Also tried this but not working
export CURL_CA_BUNDLE=""

There should be an option/way to provide the certificate file to sdkmanager.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Hi Bozkalayci1,

Sorry for the late response, may I know if this still an issue?