Failed to Flash 64 Bit OS to TX1 device

I tried to flash OS by JetPack, but failed.

Version tried: JetPack 3.2.1 (tried twice), Jetpack 2.3.1

Message from JetPack L4T on ubuntu host:

[ 2.4632 ] Flashing the device
[ 2.4657 ] tegradevflash --pt flash.bin --storageinfo storage_info.bin --create
[ 2.4670 ] Cboot version 00.01.0000
[ 3.1882 ] Writing partition GPT with gpt.bin
[ 3.1886 ] […] 100%
[ 3.1939 ] 00000007: Written less bytes than expected
[ 3.3821 ]
Error: Return value 7
Command tegradevflash --pt flash.bin --storageinfo storage_info.bin --create
Failed flashing t210ref.

Failed to flash device. Please check /home/tedxie/JetPack/_installer/logs/64_TX1/flash_os_64_tx1.log for more details. Then press Enter key and try again.

Message from serial terminal of TX1:

[1329.342] Writing protective mbr
[1329.346] Writing primary GPT
[1329.351] Writing secondary GPT
[1329.356] Found 0 GPT partitions in “sdmmc3_user”
[1329.361] device_write_gpt: failed to scan partitions in GPT!
[1329.367] Number of bytes written -1
[1329.370] Written less bytes than expected with error 0x7
[1329.376] Write command failed for GPT partition

Hi, added a comment here before I saw this thread:

Added note: You can log a command line flash. Instead of this:

sudo ./ -S 14580MiB jetson-tx1 mmcblk0p1


sudo ./ -S 14580MiB jetson-tx1 mmcblk0p1 <b>2>&1 | tee flash_log.txt</b>

Thanks for your reply.
I changed ROOTFSSIZE in jetson-tx1.conf from “14GiB” to “6GiB”, and retry. It works.

The TX1 here is customized, which has much smaller storage.