Failed to flash NVMe SSD on Nvidia Orin Nano

Hello,

Till now, I am using Micro SD Card to run deepstream on Jetson Orin Nano (with an extension of 10 GB swap memory). To further improve the performance of the deepstream pipeline, I am trying to use NVMe SSD 256 GB from Zebronics. I tried several ways to flash the SSD with SDK Manager, jetsonhacks and other ways. But, I have been unsuccessful in all ways with a common error.

Error: /dev/nvmem0: no such file or directory.

Couple of questions:

  1. Can we improve the performance of the deepstream pipeline by changing the Micro SD Card to NVMe SSD?
  2. How to setup NVMe SSD for zebronics ssd drive? (ZEBRONICS ZEB-MN26 256GB M.2 NVMe Solid State Drive (SSD), with 1900MB/s Read Speed, PCIe Gen 3.0)

Reference:
link:GitHub - jetsonhacks/bootFromExternalStorage: Shell scripts to setup a NVIDIA Jetson AGX Xavier, Xavier NX, AGX Orin, or Orin Nano Developer Kit to boot from external storage.
link:https://www.youtube.com/watch?v=q4fGac-nrTI&t=307s
link:https://www.youtube.com/watch?v=Ucg5Zqm9ZMk&t=464s

You have to first make sure the bottleneck is the disk speed.
Or you should consider different nvpmodel power mode, and also jetson_clocks.

Have you tried other NVMe drives?
I don’t think we have ever tested this ZEBRONIC brand.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.