Failed to flash with SDK Manager (Docker version)

Hi everyone,

On a Xavier NX Dev kit I have tried but failed to flash the Jetson OS from the Docker image of the Nvidia SDK Manager.
Here are the steps I have followed:

  1. Install Docker and enable to manage Docker as non-root user on my host machine (a Linux Pop!OS 20.10 BTW).

  2. Install SDK manager Docker image:
    docker load -i ./sdkmanager-
    docker tag sdkmanager: sdkmanager:latest
    docker images -a
    hello-world latest d1165f221234 4 days ago 13.3kB
    sdkmanager 37507cccf9bf 4 weeks ago 914MB
    sdkmanager latest 37507cccf9bf 4 weeks ago 914MB

  3. Plug the Xavier NX dev kit via a mini-USB to USB cable, power it up and run the following command line on the host:
    docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ --name JetPack_450_NX_Devkit sdkmanager --cli install --logintype devzone --staylogin true --product Jetson --target P3668-0000 --targetos Linux --version 4.5 --flash all --select 'Jetson OS' --deselect 'Jetson SDK Components' --license accept --datacollection enable

  4. The Jetson OS components were downloaded, but the sdkmanager failed when creating the OS image:
    Waiting for user information from NVIDIA authentication server…
    Retrieving user information…
    Loading and processing available products…
    Login succeeded.
    Loading user information…
    User information loaded successfully.
    Loading server data…
    Server data loaded successfully.
    Session initialized…

    Installation of this software is under the terms and conditions of the license agreements located in /opt/nvidia/sdkmanager/Eula/
    - Drivers for Jetson: Installed
    - File System and OS: Failed
    - Device Mode Host Setup in Flash: Failed
    - Flash Jetson Xavier NX (Devkit): Failed

    ===== Installation failed - Total 4 components =====
    ===== 1 succeeded, 3 failed, 0 up-to-date, 0 skipped =====

Here are some screenshots of the terminal log (sorry I do not know how to retrieve the logs from the docker image), we can see that some dpkg commands failed:

Did I do something wrong ?


Note to self: I have found a way to access the SDK manager logs on Docker. On your host, find the sdk manager container ID:
$ docker ps -a
e3a9f625b97e sdkmanager “docker-entrypoint.s…” 2 minutes ago Up 2 minutes JetPack_OS450_NX_Devkit

Launch a bash terminal for this container:
$ docker exec -it e3a9f625b97e bash

You are in:
nvidia@e3a9f625b97e:~$ ls .nvsdkm/
dist sdkm-2021-03-10-12-04-41.log sdkm.db sdkm.log

nvidia@e3a9f625b97e:~$ tail -n 150 .nvsdkm/sdkm.log

OK, so I have tried and failed again, same sdkmanager command line except for ‘–flash all’ replaced by ‘–flash skip’

Here is the sdkm.log file:
sdkm_20210310_1.log (71.3 KB)


I have the same result.Because I want to use sdkm in ubuntu 20.04.I use the official docker version

Hi David, AlfredNG,

Can you please try the following steps?

  1. Install “qemu-user-static” package on your host machine.
  2. Reinstall the JetPack container from scratch。

Hello,I have Install “qemu-user-static” package, but I can not flash the device. It said that flash jetson tx2 nx:failed at last.

Hi everyone,

Thanks @EdwardZhou it works ! Perhaps it will be good to add this piece of information to the SDK manager documentation here: .
FYI my host machine is Pop!OS 20.10 but I guess it will also work for other Debian based system.


Thanks David.
We’ll update SDK Manager documentation for the next release.

Can you please package and attach the ~/.nvsdkm/ directory for more investigation?
Please see Failed to flash with SDK Manager (Docker version) - #2 by david102 for the steps to access the logs.