Failed to get CRYPTO_OPERATIONAL regis

Hi,

I tried to use DPDK crypto driver, but I failed with this. I have seen an existing thread on this(Mellanox crypto drivers not working with DPDK), but I still have questions.

My problem is that I can’t get CRYPTO_OPERATIONAL:

mlxreg -d /dev/mst/mt4123_pciconf0 --reg_name CRYPTO_OPERATIONAL --get           Sending access register...                                                                                                                                      
-E- Failed to send access register: ME_ICMD_OPERATIONAL_ERROR
  • I use Connect-X6 NIC
  • I use MLNX_OFED_LINUX-5.8-2.0.3.0-ubuntu22.04-x86_64.iso and I installed it with:
    /mnt/mlnxofedinstall --without-dkms --add-kernel-support --kernel 5.15.0-67-generic --without-fw-update --force
  • ibv_devinfo output:
hca_id: mlx5_0
        transport:                      InfiniBand (0)
        fw_ver:                         20.36.1010
        node_guid:                      b83f:d203:0072:1a66
        sys_image_guid:                 b83f:d203:0072:1a66
        vendor_id:                      0x02c9
        vendor_part_id:                 4123
        hw_ver:                         0x0
        board_id:                       MT_0000000225
        phys_port_cnt:                  1
                port:   1
                        state:                  PORT_ACTIVE (4)
                        max_mtu:                4096 (5)
                        active_mtu:             1024 (3)
                        sm_lid:                 0
                        port_lid:               0
                        port_lmc:               0x00
                        link_layer:             Ethernet

  • lsmod | grep mlx output:
mlx5_ib               450560  0
mlx5_core            2039808  1 mlx5_ib
mlxdevm               176128  1 mlx5_core
ib_uverbs             143360  2 rdma_ucm,mlx5_ib
psample                20480  1 mlx5_core
mlxfw                  32768  1 mlx5_core
tls                   114688  1 mlx5_core
pci_hyperv_intf        16384  1 mlx5_core
ib_core               434176  8 rdma_cm,ib_ipoib,iw_cm,ib_umad,rdma_ucm,ib_uverbs,mlx5_ib,ib_cm
mlx_compat             69632  11 rdma_cm,ib_ipoib,mlxdevm,iw_cm,ib_umad,ib_core,rdma_ucm,ib_uverbs,mlx5_ib,ib_cm,mlx5_core
  • mlxconfig -d /dev/mst/mt4123_pciconf0 q | grep CRYPTO output (I’m not sure it’s really important):
    CRYPTO_POLICY UNRESTRICTED(1)
  1. Which drivers should be loaded for this?
  2. Which version of fw should be used?
  3. What are the steps for NIC configuration?
  4. What should I do so that I can use this driver?

I will be grateful for your answer, thank you.

1 Like

Hello,

Try to change CRYPTO_POLICY via mlxconfig to “2” instead of “1”. You should be able to run the mlxreg after that.
E.G:
mlxconfig -d s CRYPTO_POLICY=2
reboot or "mlxfwreset -d -l 3 -y reset

Best Regards,
Viki

Thank you for your reply. Unfortunately, it didn’t help me. I still see this error.

 mlxconfig -d /dev/mst/mt4123_pciconf0 q | grep CRYPTO_POLICY
         CRYPTO_POLICY                               FIPS_LEVEL_2(2)

Maybe you have other ideas?

Hi Have you solved this problem? Thanks

1 Like

Do we have any solution for this problem? Even though we bought BF2 crypto-enable, we cannot even use it.