Failed to query switch's PSID over in-band link with flint command


I am using a 56G DAC cable connecting a CX354A adapter and a SX6012 switch. The operating system is Ubuntu 18.04.2 and OFED driver version is 4.6.1.

I performed following actions:

  1. Connect the CX354A QSFP port to the switches port No.1 with Mellanox 56G DAC cable. The adapter port is set to “ib” via command “connectx_port_config”
  2. Wait a while and the infiniband link is shown as “56G” and status is “Init” in the output of “ibstatus” command.
  3. Execute command “opensm” and the link status become “Active”
  4. Run command “ibswitches” and I can see the switches id printed out in terminal.
  5. Run command “mst start” and “mst ib add”. The printouts shows the switch is added.
  6. Run command “mst status” and I can see the adapter as well as the switch.
  7. Run command “iblinkinfo” and I can see the switches ports, lid (2) as well as adapter.
  8. Run command “flint -d lid-0x2 q” or “flint -d lid-2 q” but following error occurs:

[root@localhost ~]# flint -d lid-0x2 q

-E- ibvsmad : cr access read to Lid 2 failed

-E- ibvsmad : cr access read to Lid 2 failed

FATAL - crspace read (0xf0014) failed: Invalid argument

-E- Cannot open Device: lid-0x2. Invalid argument. MFE_GENERAL_ERROR

I tried to use the other port on the adapter (it has 2 QSFP ports) as well as choose different port on the switch, but the same error occurs. I also tried to install CentOS instead of Ubuntu 18.04 and installed the same version of OFED driver but ends up in the same error.

Is there any hints about what could cause such issue? The adapter? switch? or the DAC cable? Thanks.

Hi Zenfang Wei,

Please run flint -d <mst_device> q

For example:

flint -d /dev/mst/mt4115_pciconf0.1 q

You can find the mst device by running ‘mst status -v’