Failed to restart display after loading self-compiled Image and dtb

I don’t think my problem is the same as @Dimaz

  1. After I install R34.1.1 using SDkManager, display is OK

  2. Display is failed after I compiled my own Image and replaced it

JiaZW, what is difference between Nvidia’s Image and yours?

I have transplanted the camera driver into the kernel, so there is a little difference with the official R34.1.1 kernel

Try to compile Nvidia’s sources without your changes…

1 Like

Nothing is changed, and the same is true for compiling the native kernel

Is there any code missing when compiling ???

You wrote about “little difference with the official R34.1.1 kernel”.
So I suggested to compile native sources, obtained by script.
There are only two issue, which resolved in this topic:

I used to download the source code

/net/ethernet/nvidia/nvethernet/ether_linux.h:62:10: fatal error: osi_core.h: No such file or directory

How did you solve it!!

Please check the WAR here…

Why do I still get an error when I create a soft link

ln -s …/…/…/…/…/nvethernetrm nvethernetrm

Same error or something different?

Same error

Is there any solution??

The project is now very urgent!!!

You should create symlink inside kernel/nvidia/drivers/net/ethernet/nvidia/nvethernet.
But you have created symlink inside kernel/nvidia/drivers/net/ethernet/nvidia/

thank you

Unfortunately, I compiled the Image this way (

After replacing /boot with orin

Display still doesn’t show

Still error

9.900317] systemd[1]: Started Journal Service.
[ 9.918635] nvgpu: Unknown symbol nvlink_shutdown (err -2)
[ 9.918804] nvgpu: Unknown symbol nvlink_register_link (err -2)
[ 9.919084] nvgpu: Unknown symbol nvlink_unregister_device (err -2)
[ 9.921695] systemd-journald[302]: Received client request to flush runtime journal.
[ 9.922244] nvgpu: Unknown symbol nvlink_unregister_link (err -2)
[ 9.936501] nvgpu: Unknown symbol nvlink_enumerate (err -2)
[ 9.941946] nvgpu: Unknown symbol nvlink_transition_intranode_conn_off_to_safe (err -2)
[ 9.950112] nvgpu: Unknown symbol nvlink_register_device (err -2)
[ 9.956260] nvgpu: Unknown symbol nvlink_train_intranode_conn_safe_to_hs (err -2)
[ 10.402833] nvidia: loading out-of-tree module taints kernel.
[ 10.409398] nv_platform 13800000.display: Adding to iommu group 47
[ 10.412962] platform 13800000.display:nvdisplay-niso: Adding to iommu group 48
[ 10.414331] NVRM: loading NVIDIA UNIX Kernel Module for aarch64 34.1.1 Release Build (buildbrain@mobile-u64-5414-d7000) Mon May 16 21:12:24 PDT 2022
[ 10.415017] nvgpu: Unknown symbol nvlink_shutdown (err -2)
[ 10.415206] nvgpu: Unknown symbol nvlink_register_link (err -2)
[ 10.415514] nvgpu: Unknown symbol nvlink_unregister_device (err -2)
[ 10.415783] nvgpu: Unknown symbol nvlink_unregister_link (err -2)
[ 10.416231] nvgpu: Unknown symbol nvlink_enumerate (err -2)
[ 10.416394] nvgpu: Unknown symbol nvlink_transition_intranode_conn_off_to_safe (err -2)
[ 10.424341] nvgpu: Unknown symbol nvlink_register_device (err -2)
[ 10.424592] spi-tegra114 3210000.spi: Adding to iommu group 3
[ 10.424608] nvgpu: Unknown symbol nvlink_train_intranode_conn_safe_to_hs (err -2)
[ 10.428561] spi-tegra114 3230000.spi: Adding to iommu group 3
[ 10.460383] using random self ethernet address

We’re back to where we started !!!!

Again, this nvidia.ko driver is not compatible


I have used to get sources code and use latest toolchain for L4T34.1.1.
After compiling my own Image without any change of source code, I got same error in this thread:

[    8.957540] nvgpu: Unknown symbol nvlink_shutdown (err -2)
[    8.957782] nvgpu: Unknown symbol nvlink_register_link (err -2)
[    8.958348] nvgpu: Unknown symbol nvlink_unregister_device (err -2)
[    8.958792] nvgpu: Unknown symbol nvlink_unregister_link (err -2)
[    8.965537] nvgpu: Unknown symbol nvlink_enumerate (err -2)
[    8.970513] nvgpu: Unknown symbol nvlink_transition_intranode_conn_off_to_safe (err -2)
[    8.978961] nvgpu: Unknown symbol nvlink_register_device (err -2)
[    8.984952] nvgpu: Unknown symbol nvlink_train_intranode_conn_safe_to_hs (err -2)

Comparing to L4T_32.7.1, these simpols are in sources/kernel/nvidia/drivers/nvlink/nvlink-core.c, but nvlink-core.c can’t be found in L4T_34.1.1 source folders.

Please help to check if it is missing in github repository for L4T_34.1.1

Note: Using the original Image can get display output without related errors.



That nvlink directory is not in use. It was also redundant in older release


I try to modify nvlink.c and can confirm it is not in use, but I am still not sure where the Unknown symbol error comes from.

please help to advise how to fix the above issue.



Do you only replace your kernel image? or you even replace every other kernel modules?